Page 1 of 1

3.0 time change

Posted: Sun Mar 10, 2019 9:27 am
by RBeatse
The US had time change yesterday but I am seeing an odd occurrence today. I am in Mountain Time Zone and my device says 10:24 AM. I verified the calendar is in “United States/Denver” but the little red arrow on the left of the calendar that shows the current time is showing 11:24am. If it still had the “old time”, it would say 9:24am. Odd!!

Re: 3.0 time change

Posted: Sun Mar 10, 2019 2:59 pm
by jdlessley
I can confirm the red arrow for the current time in the week view of the calendar is one hour ahead of where it should be since the time change to Daylight Saving Time. It looks like the saving time is +2 hours instead on +1 hour.

It also looks like the event graphics are off by 1 hour. For example we have an event that is from 4:20 PM to 6:30 PM, yet the graphic shows the event from 5:20 PM to 7:30 PM in the week view (The text of the graphic is still 4:20 PM to 6:30 PM).

Re: 3.0 time change

Posted: Sun Mar 10, 2019 4:12 pm
by russellhltn
Sounds like someone tried to compensate for DST but the time they were using already had DST factored in.

I noticed at least the time zone was correct. (GMT-6)

Re: 3.0 time change

Posted: Sun Mar 10, 2019 4:14 pm
by RBeatse
I agree. The code shouldn’t need to adjust. The device and server would have already adjusted on their own.

Re: 3.0 time change

Posted: Mon Mar 11, 2019 9:30 am
by CrockettDR
Here's a guess if you see this problem. In "Date Options" try changing he time zone to another time zone and then back to your correct time zone. Does that correct the arrow problem?

Re: 3.0 time change

Posted: Mon Mar 11, 2019 9:36 am
by RBeatse
I just checked my laptop and iPad and now it seems to be fixed. Maybe it took a full 24 hours.

Re: 3.0 time change

Posted: Mon Mar 11, 2019 10:27 am
by jdlessley
I did nothing as well and all appears correct today.

Re: 3.0 time change

Posted: Mon Mar 11, 2019 10:29 am
by RBeatse
Maybe time just stood still while the Rome Temple was dedicated. Maybe?