Page 1 of 1

RE: New Updates to the LDSTech Forum Software.

Posted: Wed Dec 12, 2012 4:15 pm
by jdlessley
That article states:
Single sign on
The forums now have single-sign-on integration with LDS Account. This means you won't have to sign in as often as you did before. If you're already signed in to LDS.org, for example, you won't need to re-sign in to LDSTech.


It is correct that the single sign on works if already signed on to LDS.org and then you go to LDSTech Forum. You will be signed on to the forum. Single sign on does not work when signed on to LDSTech Forum and you go to LDS.org. You still have to sign on to LDS.org.

Re: RE: New Updates to the LDSTech Forum Software.

Posted: Wed Dec 12, 2012 4:31 pm
by Gary_Miller
jdlessley wrote:That article states:
Single sign on
The forums now have single-sign-on integration with LDS Account. This means you won't have to sign in as often as you did before. If you're already signed in to LDS.org, for example, you won't need to re-sign in to LDSTech.


It is correct that the single sign on works if already signed on to LDS.org and then you go to LDSTech Forum. You will be signed on to the forum. Single sign on does not work when signed on to LDSTech Forum and you go to LDS.org. You still have to sign on to LDS.org.


If you click the sign in are on LDS.Org and it comes up as if you need to sign in just click sign in and it automatically signs you in.

Re: RE: New Updates to the LDSTech Forum Software.

Posted: Wed Dec 12, 2012 5:13 pm
by jdlessley
Gary_Miller wrote:If you click the sign in are on LDS.Org and it comes up as if you need to sign in just click sign in and it automatically signs you in.
Doesn't do that for me. I have to enter credentials.

Re: New post: New Updates to the LDSTech Forum Software.

Posted: Wed Dec 12, 2012 5:24 pm
by TimRiker
Note that signins are only valid on https, not on http. So if you follow a link to:

http://www.lds.org/
http://tech.lds.org/

Your login information would not be displayed. In this case, hitting the signin should just sign you in without asking for credentials. If your session timed out before following the link, then it would ask for credentials.

Hmm.. if I signin on https://tech.lds.org/ and then hit the church logo I stay signed in. If I do the same on the forum, I did not stay logged in. Need to figure out why.

Is this what you are seeing?

Re: RE: New Updates to the LDSTech Forum Software.

Posted: Wed Dec 12, 2012 5:37 pm
by jdlessley
I tested two methods to get to LDS.org after signing in to the forums. Both had http instead of https. The first was a bookmark - I can fix that. The other was the Church logo link in the forum page header- that will have to be fixed by a programmer.

I changed my bookmark and it works as it should.

Re: RE: New Updates to the LDSTech Forum Software.

Posted: Wed Dec 12, 2012 5:56 pm
by TimRiker
I updated the style so the image links to //www.lds.org without a protocol. it should stay http or https depending on how you are connected to the forums. Does this fix the issue for people?

Re: RE: New Updates to the LDSTech Forum Software.

Posted: Wed Dec 12, 2012 10:59 pm
by jdlessley
It fixed it for me.