TechForumProjects

User talk:Aggie107

My droid tablet will not let me download lds tools

5 months ago I was called as Bishop. I couple of weeks ago I decided to start using a Galaxy Tab 4 in my calling, unfortunately I cannot get LDS Tools to download into my tablet. I get an error indicating that a message indicating that "Your device isn't compatible with this version". I have done everything I can think of to update the device including a hard reset and wipe. The application works perfectly on my Samsung S7 phone.

I would love suggestions!

User:TimRiker - This is not a support forum. The Android LDS Tools are here:

https://tech.lds.org/forum/viewforum.php?f=116

You make want to contact the Global Service Center

This page was last modified on 10 January 2019, at 21:15.

Note: Content found in this wiki may not always reflect official Church information.