Page 1 of 2

Supported iOS versions for Gospel Library

Posted: Mon Apr 29, 2019 10:20 am
by sbradshaw
Availability of Church content is a priority for those who support the Gospel Library app. Unfortunately, as mobile ecosystems change, it's impossible to continually improve the app while supporting older devices indefinitely.

Only the newest versions of Gospel Library will continue to receive the newest content (new general conferences, magazines, devotionals, curriculum, editions of the scriptures, etc.). The content format used by the app changes with major app releases to support new features. As an analogy, you can think of this as switching content from PowerPoint files to Word files. The new format allows us to do more, but is not compatible with the old app. For a little while, as users transition from the old version of the app to the new, the content team produces both (continuing the analogy) a PowerPoint and a Word file of each content item, but eventually, the old file type is phased out to focus resources on providing more and better content in the new format.

In addition to content format changes, sometimes changes are made on the Church servers that prevent older devices from establishing a connection. For example, recently the Church servers were updated to newer security protocols (http:// to https://, TLS 1.2). Older versions of Android and iOS don't support the latest security standards, so they are no longer able to authenticate with the Church's servers for sign-in, annotation sync, or role-based content. The Church is a continual target for those who want to do harm, so keeping security standards up to date, while it provides inconvenience at times, protects the Church and its members.

If your device doesn't support the newest Gospel Library, don't feel obligated to buy a new device. The Church doesn't require members to use the newest technology to study the gospel – Gospel Library is provided as a tool for those who are able to benefit from it. If you are on an older device, you can access the newest content by browsing LDS.org, by downloading PDFs to your device, or using an e-book reader. If you don't have a smart device at all, the Church continues to provide scriptures and other core content in print format. We know that transitions are difficult and we hope that you will be able to continue growing in faith through consistent gospel study, no matter your circumstance.

If you are considering purchasing an iPhone, iPad, or iPod touch to use Gospel Library or other Church apps, check the iOS version. I wouldn't recommend any iOS version below iOS 12. iOS 11 is the minimum supported iOS version for most Church apps, and any device that supports iOS 11 is able to update to iOS 12. Newer devices will almost always provide a smoother experience and will last farther into the future.

For historical reference, these are the iOS versions where support has changed:
  • If you're on iOS 3 and up, your device will run Gospel Library 2.0.3. (No longer available, and not receiving content updates.)
  • If you're on iOS 3.1.3 and up, your device will run Gospel Library 2.5.0. (No longer available, and not receiving content updates.)
  • If you're on iOS 6.1 and up, your device will run Gospel Library 3.4.13. (No longer receiving content updates.)
  • If you're on iOS 9 and up, your device will run Gospel Library 4.4.0. (No longer receiving content updates after March 2019.)
  • If you're on iOS 10 and up, your device will run Gospel Library 5.1.1. (Content updates will continue for the foreseeable future.)
  • If you're on iOS 11 and up, your device will run the latest version of Gospel Library. (Content updates will continue for the foreseeable future.)

Re: Supported iOS versions for Gospel Library

Posted: Mon Apr 29, 2019 12:19 pm
by jokendean
how can I download Gospel Library version 4.4.0 ?

Re: Supported iOS versions for Gospel Library

Posted: Mon Apr 29, 2019 2:25 pm
by sbradshaw
jokendean wrote:how can I download Gospel Library version 4.4.0 ?

The iOS App Store keeps track of any apps you install with your Apple ID. If you've installed Gospel Library in the past (on any device), you can find it in the "Purchased" tab of the App Store. From there, you can download the most recent version of the app that's compatible with your device. Unfortunately, if you've never installed the app before on any of your devices, it won't show up on the list. As a workaround, if you have a newer device and an older device, if you install the app on the newer device, it will become available in the Purchased list on the older device.

Re: Supported iOS versions for Gospel Library

Posted: Sun May 05, 2019 10:49 am
by JonathanCello
Does anyone know how to access developer mode for the library app on iPhone?

Re: Supported iOS versions for Gospel Library

Posted: Sun May 05, 2019 12:40 pm
by jdlessley
JonathanCello wrote:Does anyone know how to access developer mode for the library app on iPhone?

The developer mode is not available for the Gospel Library except by the development team programmers at church headquarters.

Re: Supported iOS versions for Gospel Library

Posted: Sun May 12, 2019 9:18 am
by geysser
So we have 3 grandchildren who own ipad's with ios 9.3.5. Now they won't be able to get updated info on the Gospel Library unless they all buy new ipads? Do the general authorities know this. It appears you have taken a most valuable resource away from those who can't afford to upgrade their ipads? This isn't a local issue, it's worldwide.

I believe that general authorities know this if they don't already. I can't believe they would exclude members from a rich and valuable resource.

Thanks.

Re: Supported iOS versions for Gospel Library

Posted: Sun May 12, 2019 10:35 am
by russellhltn
geysser wrote:Do the general authorities know this. It appears you have taken a most valuable resource away from those who can't afford to upgrade their ipads? This isn't a local issue, it's worldwide.

This isn't really the church's decision.
  • Apple chose to stop issuing iOS updates for those model iPads.
  • Apple has update polices that lock-in the application for those older units and prevents updates.
Once the church has need to update the app, in part to change servers and in part to secure the Church Account login (standards do change), these older devices are left behind.

It's really not the church's choice. If you want to run on Apple's platform, you play by Apple's rules.

Re: Supported iOS versions for Gospel Library

Posted: Sat May 18, 2019 12:03 pm
by pauldeis
Thank you sincerely sbradshaw for the explanation regarding the AppStore keeping track of previously purchased apps; I was able to download the most recent, compatible version and saved a lot of grief.

Re: Supported iOS versions for Gospel Library

Posted: Mon Jun 17, 2019 8:36 pm
by ulupoi
Excellent answers. Thank you very much for taking the time to post them.

Re: Supported iOS versions for Gospel Library

Posted: Mon Jun 17, 2019 11:37 pm
by ulupoi
For those with old devices, here is the URL (https://www.churchofjesuschrist.org/med ... s?lang=eng) for the Church website with materials in formats that will still work for you, for example:

1. PDF
2. ePub (Instructions on how to read ePub files can be found here: https://www.wikihow.com/Open-EPUB-Files)
3. Kindle/MOBI


Printed scriptures. Since 1454 or 1455. End of support date: never.
Gutenberg!