All-day events off by a day on sync

Discussions about the Calendar Tool at lds.org. Questions about the calendar on the classic site should be posted in the LUWS forum.
russellhltn
Community Administrator
Posts: 26403
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Tue Nov 01, 2011 11:00 am

I think all of my "all day" events were holidays which I had to re-create. Is this an event that migrated from V1, or something created in V2 after the fix was announced, or in between?
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

tregis
New Member
Posts: 7
Joined: Sat Jan 05, 2008 10:27 am
Location: Fayetteville, NC USA

Postby tregis » Tue Nov 01, 2011 1:29 pm

RussellHltn wrote:I think all of my "all day" events were holidays which I had to re-create. Is this an event that migrated from V1, or something created in V2 after the fix was announced, or in between?

I have the same problem here on the East Coast. This is with the all day events entered into the new version of the calendar. Most were after the last fixed was announced.

mwgrover
Member
Posts: 85
Joined: Sun Jul 11, 2010 9:19 pm
Location: Broken Arrow, OK, USA

Postby mwgrover » Wed Nov 02, 2011 7:14 pm

sachsen wrote:My bug:

When I look at the calendar on the website, the all-day events that our stake has entered (such as Family Home Evenings, Fast Sundays, Stake Conference, etc.) are all correct. However, when I sync/subscribe to my iCal calendar on my Mac, those events are all behind one day - Fast Sundays are on Saturday, Family Home Evenings are on Sunday, Stake Conference is Fri-Sat instead of Sat-Sun, etc.

I already tried deleting my sync subscription and re-copying the URL. Like I said, it is only the all-day events that are wrong. The events scheduled with a specific time are on the correct day in iCal.


This is fixed now - thanks!

Aczlan
Member
Posts: 353
Joined: Sun Jun 06, 2010 4:29 pm
Location: Upstate, NY, USA

Postby Aczlan » Wed Nov 02, 2011 7:32 pm

sachsen wrote:This is fixed now - thanks!


Same here.

Aaron Z

nathan.g
New Member
Posts: 18
Joined: Thu Mar 31, 2011 11:36 pm
Location: Christchurch, New Zealand

Postby nathan.g » Thu Nov 03, 2011 12:24 am

All fixed! Many thanks!

elvidgeps
New Member
Posts: 4
Joined: Mon Feb 07, 2011 4:42 am

Postby elvidgeps » Thu Nov 03, 2011 5:36 am

All day events seem FIXED as of this morning GMT-0. Well done.

coreysprague
New Member
Posts: 5
Joined: Tue Feb 15, 2011 3:28 pm

Postby coreysprague » Mon Dec 12, 2011 9:42 pm

I cannot tell if this bug is supposed to have been fixed or if everyone has just thrown up their hands and accepted it as an unfixable bug. Seriously? My stake uses a PC-based calendar program during the planning period, which I then export to CSV. I've written a program that converts the CSV into an iCal standard format. Upload goes fine except for all-day events. LDS Calendar moves it to the previous day and slaps an 11:00pm time on it. This happens whether I use DTSTART=yyyymmdd or DTSTART;VALUE=DATE:yyyymmdd, and regardless of whether there is a DTEND value or not. I've tried several modifications and it looks like I will be forced to manually enter/edit my all-day events. Is there no way to get this fixed?

russellhltn
Community Administrator
Posts: 26403
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Mon Dec 12, 2011 10:09 pm

coreysprague wrote:I cannot tell if this bug is supposed to have been fixed or if everyone has just thrown up their hands and accepted it as an unfixable bug.


Is there any time zone set in your file?
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

coreysprague
New Member
Posts: 5
Joined: Tue Feb 15, 2011 3:28 pm

Postby coreysprague » Tue Dec 13, 2011 8:39 am

RussellHltn wrote:Is there any time zone set in your file?


I am currently using the Google timezone spec: X-WR-TIMEZONE:America/Los_Angeles, but I've also tried VTIMEZONE/TZID spec with no success.

russellhltn
Community Administrator
Posts: 26403
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Tue Dec 13, 2011 10:31 am

Just for fun, I exported the old calendar, since I've been told it will import properly into the new one. Here's what I get for a start:

Code: Select all

BEGIN:VTIMEZONE
TZID:US/Mountain
LAST-MODIFIED:20060203
BEGIN:STANDARD
DTSTART:19671029T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
TZOFFSETFROM:-0600
TZOFFSETTO:-0700
TZNAME:MST
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:19870405T020000
RRULE:FREQ=YEARLY;BYDAY=1SU;BYMONTH=4
TZOFFSETFROM:-0700
TZOFFSETTO:-0600
TZNAME:MDT
END:DAYLIGHT
END:VTIMEZONE


Note that I am NOT in the MST/MDT time zone.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.


Return to “Calendar”

Who is online

Users browsing this forum: No registered users and 1 guest