Page 1 of 2

Formatting for "send a message"

Posted: Sat Feb 29, 2020 11:45 am
by cntaylor
Is there a way to check your formatting in "send a message" before it gets sent out. I usually use pretty straight-forward formatting, but half the time the separation between my paragraphs disappear, half the time they don't. There are several other annoying things, but the changing of whitespace makes most the e-mails I send to my ward look very unprofessional. I can't figure out when "send a message" keeps the white space and when it doesn't. Ideas?

Re: Formatting for "send a message"

Posted: Mon Mar 02, 2020 6:31 am
by lajackson
cntaylor wrote:Is there a way to check your formatting in "send a message" before it gets sent out.

I am not aware of a way, other than just sending it through the system to yourself.

I write all my messages in a text or Wordpad file. It is decidedly low tech, but the email usually comes through as it appeared when I pasted it into the online app. You also have limited formatting capability at the website. (Very limited.)

Re: Formatting for "send a message"

Posted: Sat Mar 21, 2020 10:37 pm
by drewsky5
I just sent an email to all the members of the ward and just about all the special formatting was removed from the actual send. What's the point of having rich formatting for composing a message if it doesn't get used when sent?

Re: Formatting for "send a message"

Posted: Sun Mar 22, 2020 9:19 am
by scgallafent
drewsky5 wrote:I just sent an email to all the members of the ward and just about all the special formatting was removed from the actual send. What's the point of having rich formatting for composing a message if it doesn't get used when sent?

The point was never to have a full-featured rich formatter. When we implemented the formatting in the editor, we made a specific, conscious decision to support some basic formatting but not to try to implement a full-featured editor.

Re: Formatting for "send a message"

Posted: Sat Mar 28, 2020 1:54 pm
by drewsky5
scgallafent wrote:
drewsky5 wrote:I just sent an email to all the members of the ward and just about all the special formatting was removed from the actual send. What's the point of having rich formatting for composing a message if it doesn't get used when sent?

The point was never to have a full-featured rich formatter. When we implemented the formatting in the editor, we made a specific, conscious decision to support some basic formatting but not to try to implement a full-featured editor.


I can certainly understand that. However, if the basic formatting you refer to is things like bold, italics, font sizes, or spacing between paragraphs, then it doesn't seem to be respecting those, either. I've tried pasting formatted text into the editor, as well as making changes directly in the editor and neither appear to work.

Re: Formatting for "send a message"

Posted: Sat Mar 28, 2020 5:23 pm
by lajackson
drewsky5 wrote:However, if the basic formatting you refer to is things like bold, italics, font sizes, or spacing between paragraphs, then it doesn't seem to be respecting those, either. I've tried pasting formatted text into the editor, as well as making changes directly in the editor and neither appear to work.

I used notepad to create a message with some bold text. When I pasted the message into Send a Message, all of the bold highlighting was gone.

In Send a Message, I bolded the text again and sent the message. The message I received back had the bold sentences in it, just as I had prepared it in Send a Message. I have not checked with others to see if the bold formatting showed up in their messaging programs.

Re: Formatting for "send a message"

Posted: Mon Mar 30, 2020 6:46 am
by zaneclark
I use Notes on my Mac to create my newsletter, and I also found that some formatting, including bold text, will not appear in Send a Message, so after I paste it, I use the formatting there to finish the newsletter before I send it out. Seems to work pretty good, including bold, color text, etc.

Re: Formatting for "send a message"

Posted: Sun Apr 12, 2020 5:01 am
by lajackson
lajackson wrote:The message I received back had the bold sentences in it, just as I had prepared it in Send a Message.

I had a different experience this morning. With Send a Message displaying exactly the way I wanted to see the email appear, I sent the message. It included some bolding and double spacing between paragraphs, and a few indented bullet points, no other formatting at all.

The message delivered was one continuous blur of words, zero bold, no spaces between paragraphs or sentences. It was the lesson for our elders quorum today. I doubt that anyone will read it and I look like an idiot. The quorum instructor will think I have gone rogue. This is so disappointing, that Send a Message would not even deliver what it was showing when I pressed the button.

Here is the four-letter word of the day: sigh.

Re: Formatting for "send a message"

Posted: Sun Apr 12, 2020 5:25 am
by drepouille
Perhaps a PDF attachment is the way to go?

Re: Formatting for "send a message"

Posted: Sun Apr 12, 2020 12:58 pm
by lajackson
drepouille wrote:Perhaps a PDF attachment is the way to go?

Too complicated for most of the quorum. Many can barely open the email and fewer are able to download an attachment.

Some bolding of titles. A blank line between paragraphs. That is all I ask. And I had thought those little buttons above the text box at Send a Message would have provided that. What is disappointing is that, apparently, what you see is not what you get, even in the simple things at SaM.

There was one small difference in the way this morning's email was prepared for sending that seems to have made a terrible difference in the delivered result. I am looking into whether or not that was the cause. If my theory is correct, then what you see in the text box does not correctly represent what is stored for sending on the actual page at the site. I will know after I send the next few emails.