Page 1 of 1

Photos Not Appearing in LDS Tools

Posted: Sun Apr 30, 2017 4:42 pm
by Hilohi
The individual photos for some of our members are not appearing in LDS Tools. This problem appears to be random. For example, this morning I uploaded individual photos for a couple (via Google Chrome from my desktop computer). Several hours later I sync'd LDS Tools (iOS), and the husband's individual photo appears, but not the wife's. Does anyone know how to resolve this problem?

Re: Photos Not Appearing in LDS Tools

Posted: Sun Apr 30, 2017 5:48 pm
by jdlessley
All photos must be approved by a Directory administrator (bishopric member, clerk, assistant clerk, or assistant clerk - membership) before being available for viewing to the general membership. While the photos can be viewed by members with certain leadership callings, those photos are not, or should not be, visible to the general membership. There has been bugs in LDS Tools that allowed uploaded photos to be visible to everyone right after the upload in LDS Tools but not visible in the LDS.org Directory. What is being experienced here may be related to that bug.

A Directory administrator should check to see if the photos have been approved, and approve them, if appropriate, before pursuing any concerns about the apparent random display of some photos in LDS Tools and not others. If they haven't been approved in the LDS.org Directory and they are appearing in LDS Tools then the bug in LDS Tools is still the issue.

Re: Photos Not Appearing in LDS Tools

Posted: Sun Apr 30, 2017 5:55 pm
by Hilohi
jdlessley wrote:All photos must be approved by a Directory administrator (bishopric member, clerk, assistant clerk, or assistant clerk - membership) before being available for viewing to the general membership. While the photos can be viewed by members with certain leadership callings, those photos are not, or should not be, visible to the general membership. There has been bugs in LDS Tools that allowed uploaded photos to be visible to everyone right after the upload in LDS Tools but not visible in the LDS.org Directory. What is being experienced here may be related to that bug.

A Directory administrator should check to see if the photos have been approved, and approve them, if appropriate, before pursuing any concerns about the apparent random display of some photos in LDS Tools and not others. If they haven't been approved in the LDS.org Directory and they are appearing in LDS Tools then the bug in LDS Tools is still the issue.


I'm the ward clerk so the photos have been approved. That said, it sounds like my problem of some photos not appearing in LDS Tools is caused by the bug you mentioned. By the way, hasn't this photo bug been ongoing for almost a year now?

Re: Photos Not Appearing in LDS Tools

Posted: Fri May 05, 2017 10:16 am
by 1chrisbrown
I am also a ward clerk. We have the same issue. Many photos appear on LDS.org, and not in LDS tools. All photos have been approved.

Re: Photos Not Appearing in LDS Tools

Posted: Mon Jul 10, 2017 4:58 pm
by mread62358
Same problem for me, on-going. I have approval authority and after approving new photos on LDS.org, some (mostly in the past) do appear in LDStools, most do not. Specifically, both Household and Individual photos can be views in LDStools when the individual record is viewed, but the little round "icon" (or avatar or whatever) images, which are derived from the Individual photo, do NOT appear. I can find no way to force the Individual photo to "propagate" to the little icon image.
This does sound related to the bug mentioned above. Any way to get a tracking number for the bug to monitor a solution?

Re: Photos Not Appearing in LDS Tools

Posted: Tue Jul 11, 2017 1:08 am
by johnshaw
Oh, man... you asked for a tracking number for the bug... that cracks me up.

Re: Photos Not Appearing in LDS Tools

Posted: Tue Jul 11, 2017 9:06 am
by sbradshaw
If you send feedback through the app, your feedback will be assigned a ticket number.

Do you have the "Download Photos" switch turned on in Settings?

Re: Photos Not Appearing in LDS Tools

Posted: Tue Jul 11, 2017 9:10 am
by lajackson
mread62358 wrote:Any way to get a tracking number for the bug to monitor a solution?

First of all, this is a user-to-user forum. Bugs are not tracked here. In fact, the developers rarely frequent these pages.

The best way to report a problem is to submit Feedback through the links on LDS.org pages, if you saw the problem there, or through the Feedback mechanism within the app, if the problem is there. As sbradshaw pointed out, if you send feedback through the app, your feedback will be assigned a ticket number.

The developers will see your feedback, although you will not always get a response from them. They do have a system for tracking needed changes, but do not usually share that information publically, because so much more is involved than just tracking the bug.

Re: Photos Not Appearing in LDS Tools

Posted: Tue Jul 11, 2017 9:40 am
by johnshaw
You might also join the beta community for LDS Tools, the developer participates often there.