Error handling for use of HTML tag characters

The Newsletter application will eventually appear alongside Calendar, Directory, and Maps
Post Reply
mandjreid
New Member
Posts: 9
Joined: Tue Sep 13, 2011 4:24 pm

Error handling for use of HTML tag characters

Post by mandjreid »

I tried using the < and > characters in the article text, and when Adding the article those characters and all between them were dropped from the text field. They probably need to be encoded on entry and decoded on display -- or the user should get an error message saying the characters aren't allowed.

Thanks!
mandjreid
New Member
Posts: 9
Joined: Tue Sep 13, 2011 4:24 pm

Post by mandjreid »

Sorry -- I should add here that the first display of those characters is fine, but when I go to re-edit the article, it gets dropped. So it's on the edit form display and not the post or read-only display where it gets dropped.
cognifloyd
Member
Posts: 67
Joined: Mon Aug 24, 2009 10:39 am
Location: Salt Lake City, UT, USA
Contact:

Post by cognifloyd »

Works for me.
I can add < and > on separate lines, on the same line, with spaces in, and without. I've even tried <div>, and the < and > show up just fine in the output - they are properly encoded/escaped.
cognifloyd
Member
Posts: 67
Joined: Mon Aug 24, 2009 10:39 am
Location: Salt Lake City, UT, USA
Contact:

Post by cognifloyd »

I can verify this. < and > can be posted the first time, but everything between them is dropped on edit.
Post Reply

Return to “Beta Newsletter”