Page 1 of 1

clerksupport site displaying in Spanish

Posted: Sun Aug 24, 2014 12:12 pm
by craiggsmith
clerksupport.lds.org is displaying in Spanish for me today. Anyone else? I've tried 3 different browsers with the same result. lds.org is fine.

clerksupport also was fine when I logged in at church today on an old WinXP machine.

Re: clerksupport site displaying in Spanish

Posted: Sun Aug 24, 2014 12:20 pm
by russellhltn
lds.org does that from time to time. Not sure why they have such a hard time figuring out the default language.

Works fine for me, but it was giving me grief a few weeks ago. I just edit the url.

Re: clerksupport site displaying in Spanish

Posted: Sun Aug 24, 2014 1:56 pm
by craiggsmith
I remember hearing about this a long time ago but never had an issue and thought they fixed it. I thought it strange that I could go back and forth between lds.org and clerksupport.lds.org and one was consistently english and the other consistently spanish. I had to download the MLS installer and don't speak spanish, but was able to figure it out. It's fine now at any rate.

Re: clerksupport site displaying in Spanish

Posted: Thu Jul 09, 2015 7:15 pm
by champted
lds.org does that from time to time. Not sure why they have such a hard time figuring out the default language.

Works fine for me, but it was giving me grief a few weeks ago. I just edit the url.


I am having this problem now. When I edit the URL from spa to eng, the page I land on says that I'm in "Canada - English". When I try to change the country to USA by clicking "Canada - English", then "select country", then click on North America, "United States" is not a selection in the region of North America. Caribbean in 3 languages, Canada in 2 languages, Mexico, but no USA.