Page 1 of 1

Books won't download

Posted: Fri Feb 08, 2019 10:15 pm
by jmillar771
I just installed GL on my new Microsoft Surface and it's not downloading many of the books, including the standard works. I click the books and nothing happens. It also looks like the catalog is not updating past October 2017. There are no ensigns available after that point. Interestingly, it did download the updated handbook 2 as of December 2018.

Let me know if anyone has any thoughts.

Re: Books won't download

Posted: Fri Feb 08, 2019 10:48 pm
by carsonm
Depending on the Update version/build you have of Windows 10, you may be able to reset the app.

That is basically done by doing the following.

Windows 10 app reset
Open the Settings app (looks like a gear) , and reset a desired app. Here's how to do that:
Open Settings.
Go to System > Apps & features.
Find an app you want to reset, and click on Advanced options.
Just click the Reset button.

Once you have done that, open up the Gospel Library app and then you should be able to download the latest books.
You may want to close the Gospel Library app before resetting it.

Hope that helps.

Re: Books won't download

Posted: Sat Feb 09, 2019 1:54 pm
by jmillar771
Thanks for your reply. None of the above worked, unfortunately. I've uninstalled, redownloaded and reinstalled it multiple times. I've tried the beta app several times as well. I even reset the Surface to factory and reinstalled windows and it still doesn't work to download. My version of windows is windows 10 Home, I believe.

When it goes through the startup sequence, it looks like it skips over syncing annotations and has a red circle with an x for checking for role based content. Not sure what else to try. Could there be something wrong with where the app is looking for content? It appears to be stuck with content dated back in October 2017.

Re: Books won't download

Posted: Sat Feb 09, 2019 2:00 pm
by jmillar771
So I tried the Preview app and that seems to be working actually! Not sure why neither the Beta nor the normal release is working :(.

Thanks for such a great app by the way. I wanted to let you know that it is my favorite way to manage my scripture study and church work. I saw from another post that you were working on a major release. I'll keep a look out for it in the near future!

Re: Books won't download

Posted: Mon Feb 11, 2019 8:45 am
by sbradshaw
Having a catalog more than a month or two old would prevent books from downloading, because older catalogs point to older versions of books, which may no longer be on the Church's servers. It's possible the preview version of the app came bundled with or installed a new catalog. Normally, the catalog should be updated automatically when you use the app.

Re: Books won't download

Posted: Sun Feb 17, 2019 9:41 am
by jmillar771
I agree, I would think the catalog would update under normal usage, but what I'm saying is that it is not updating on the regular windows store version of gospel library for me. Not sure what is causing it or why it's not working. Only the preview seems to work. I'll try installing GL again this afternoon to see if the issue has resolved.

Re: Books won't download

Posted: Sun Feb 17, 2019 2:23 pm
by carsonm
Interesting. I am wondering what update version of Windows 10 you have on your Surface and which Surface pro model you have (if you have pro and not the new Surface Go) The latest Surface Pro is on generation 6 now. Which generation of the Surface Pro do you have?

Here is a quick list of which Update version of Windows 10 there are: ... on_history (in the Rings section)

You can check you version in Settings ->System ->About on your Windows 10 device.

Once we have that information, we can see if someone else can replicate the issue with the same setup as you and hopefully determine the cause of the issue you are experiencing and then a resolution.

Re: Books won't download

Posted: Fri Feb 22, 2019 7:27 pm
by jmillar771
Sorry for my slow response. I have the Surface Pro 6 with Windows 10 - version 1803.

It looks like a recent update to the app (or something else) has now fixed the issue. I'm able to now download content on the regular Gospel Library release. Thanks for your patience.