No suitable Java VM found / XUbuntu 14.04/32bit

Issues related to FamilySearch Indexing
New Member
Posts: 5
Joined: Wed Dec 21, 2011 11:53 am

No suitable Java VM found / XUbuntu 14.04/32bit

Postby dfrandin » Wed Jul 20, 2016 10:39 am

One of the ward members who I moved to Linux a few years ago saw a prompt on her computer to upgrade it from XUbuntu 12.04 to 14.04, so she clicked it, and then walked away, and forgot about it. Along comes hubby and noticing the laptop was still turned on but with a screen blanker, turned it off.. When the good sister tried to start her machine, it spouted a bunch of errors and thats when she called me. I decided to backup her /home directory and do a clean install of XUbuntu. At the moment, I've completed *everything* but her install of the Indexing program. Having not had to install it for quite a while, I somewhat expected it to install without any problems on a 32bit Linux. Apparently I was mistaken.. Each attempt to install the Indexing app gives me the following error:

Code: Select all

lori@D620:~/Desktop$ ./
testing JVM in /usr ...
testing JVM in /usr/lib/jvm/default-java ...
testing JVM in /usr/lib/jvm/java-1.7.0-openjdk-i386 ...
testing JVM in /usr/lib/jvm/java-7-openjdk-i386 ...
No suitable Java Virtual Machine could be found on your system.
The version of the JVM must be at least 1.6 and at most 1.6.
Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.
You can also try to delete the JVM cache file /home/lori/.install4j

The one part of that error makes me curious, assuming its not
a error itself is WHY is such an ancient Java version still being used?
I'm a retired sysadmin/support tech, and I retired in 2010, and 1.6
was considered old at *that* time.. The system has a valid 1.7 version
on it. I tried pointing INSTALL4J to all of the above with zero success..

Just for fun, I went to the Oracle Java 1.6 website and they state
WARNING: These older versions of the JRE and JDK are provided to help
developers debug issues in older systems. They are not updated with the
latest security patches and are not recommended for use in production.


New Member
Posts: 1
Joined: Wed Jul 20, 2016 6:35 pm

Re: No suitable Java VM found / XUbuntu 14.04/32bit

Postby TobonJ » Wed Jul 20, 2016 6:44 pm

This patch has worked perfectly for me and my Ubuntu 14.04 netbooks. It was designed by someone for whom I am so grateful.
I created a file that I called and run it: sudo bash and then I simply wait it does everything I need to make it work.

#Familysearch Indexing does not currently install on 64 bit
#Ubuntu 14.04(or 64 bit linux in general).
#This script runs necessary commands to fix that.
#All fixes are not mine, thank this guy:

wget -c ...
echo "DONE"
echo '--- 2013-11-05 11:34:03.000000000 -0700
+++ 2013-11-17 20:23:14.782527336 -0700
@@ -348,6 +348,9 @@
cd ..

+for f in "$bundled_jre_home"/bin/*; do
+ ln -fs /usr/lib/jvm/java-6-openjdk-amd64/bin/$(basename $f) "$f"
run_unpack200 "$bundled_jre_home"
run_unpack200 "$bundled_jre_home/jre"
else' > Indexing_unix.PATCH

patch Indexing_unix.PATCH
echo "DONE"

#libraries and finally, java jre 6
sudo apt-get install -y libgtk2.0-0:i386 libxtst6:i386 libxtst6:i386 libx11-dev:i386 lib32z1 lib32ncurses5 lib32bz2-1.0 libxi6 libxtst6 libxrender1

sudo apt-get install -y openjdk-6-jre

sudo update-alternatives --install "/usr/bin/java" "java" "/usr/lib/jvm/jdk1.6.0-openjdk-amd64/jre/bin/java" 1
sudo update-alternatives --install "/usr/bin/javac" "javac" "/usr/lib/jvm/jdk1.6.0-openjdk-amd64/jre/bin/javac" 1

echo "It will be alright in the end"
chmod +x

New Member
Posts: 5
Joined: Wed Dec 21, 2011 11:53 am

Re: No suitable Java VM found / XUbuntu 14.04/32bit

Postby dfrandin » Thu Jul 21, 2016 6:54 am

Reluctantly, I went ahead and installed Java 1.6 and it worked... I guess if the devs are all busy working on the web-based Indexing project, nobody has the time/inclination to update the current Indexer to a bit more moden JRE..

Return to “FamilySearch Indexing”

Who is online

Users browsing this forum: No registered users and 1 guest