Page 1 of 1

Footnote display bug

Posted: Thu May 15, 2014 12:59 am
by lfalin
Summary: When viewing the online scriptures, certain URLs cause the footnotes to disappear. Clicking on Show Footnotes reloads the page, but no footnote links are displayed. Removing cookies and clearing the cache has no effect on this problem.

Expected Behavior: Footnotes should display when Show Footnotes is clicked, and hide when Hide Footnotes is clicked. This setting should persist across sessions.

Steps to reproduce:
Behavior experienced with Mac OS 10.9.2 testing with each of the following browsers:
Google Chrome 34.0.1847.131
Safari 7.0.3
Firefox 29.0.1
Also experienced on Windows 7 SP1 x64 using the following browsers:
Google Chrome 34.0.1847.131

1. Go to
2. Footnotes appear as expected. If they aren't showing, click "Show Footnotes". Page will reload showing footnotes.
3. Click the "Next" button to go to Genesis 2
4. The URL which is loaded is
5. Footnotes don't appear. Clicking "Show Footnotes" reloads the page, and sets the proper cookie values, but footnotes still don't appear.

Workaround Options:
1. Manually change the URL to remove the ?lang=eng query parameter. The footnotes then appear and behave as expected.

2. Manually change the URL to change the query string to ?lang=spa. The page reloads in Spanish and the footnotes appear and behave as expected.

Re: Footnote display bug

Posted: Thu May 15, 2014 3:17 am
by lfalin
Further investigation leads me to suspect that there's some kind of server-side caching that's to blame here. To make sure it wasn't the client caching things, I completely disabled caching using Chrome's dev tools.

Any change to the query string in the URL causes the value in the footnote cookie to be honored. So while this URL doesn't show footnotes for me:
These both do: ... m=whatever

I also tried setting the Cache-Control header in the request header to no-cache using Chrome's REST Console tool, but there was no difference in behavior.

Re: Footnote display bug

Posted: Tue May 20, 2014 5:00 am
by sylviachristensen
Thank you for this posting! I found it through Google, and I found that removing the language query worked except for Psalms 118. I was working in Chrome, and nothing worked there. However, when I went to both Firefox and IE, the footnotes displayed without modifying the URL. Previously, I had not had the experience, and I had tried all three browsers. I am working in Windows 7 on a PC. Don't know if this will add to the diagnosis or not. I'm not that tech savvy.

Re: Footnote display bug

Posted: Tue May 20, 2014 8:32 pm
by chuefner
Tried the suggested workaround (deleting "?lang=eng"), but success in seeing the footnotes seemed to be almost entirely random (other than in the chapters shown as examples above), although adding "&random=whatever" to the URL seemed to work in all views that I tried it in.

Bizarrely enough, when I searched for Psalm 118, the footnotes showed without my doing anything (and continued to show when I used the "next" link to move to 119, and then 120, whereas all other tries at using the "next" link elsewhere always kicked out the footnotes and the "show footnote" link would not function properly).

FWIW, I submitted a feedback comment on this through and received a response saying that many people were asking about this problem. But the response suggested that this was a browser problem, and perhaps a problem due to a full browser cache. Like #3 above, I have experienced the same problem on multiple computers/devices and using four different browsers.

Re: Footnote display bug

Posted: Wed May 21, 2014 4:31 am
by sylviachristensen
This is so random. Psalms 118 doesn't work this morning for me again, even when deleting as suggested in #2, but adding &random=whatever brought the footnotes up. Cache and cookies are emptied. Guess I'll just take the advice of some talented "techies" and study. Thanks