Page 1 of 1

"Search Scriptures" no longer recognizes hyphens in scripture reference

Posted: Fri Apr 13, 2018 3:22 am
by panders12
I noticed an issue which appeared yesterday with the "search scriptures" box on lds.org. When I run a search involving multiple verses separated by a hyphen, lds.org no longer interprets it correctly. I use this function everyday, so I know that it was working correctly until yesterday.

Here's the issue:
If I type "alma 53:13-15" in the search box, I expect to be taken to the alma 53 page with verses 13-15 highlighted and with the page scrolled down to about verse 12. Here's the url I typically get in response to that search:
https://www.lds.org/scriptures/bofm/alma/53.13-15?lang=eng#p12

However, starting yesterday, that search generates this URL instead, which doesn't highlight the verses or scroll correctly:
https://www.lds.org/scriptures/bofm/alma/53.1315?lang=eng#p1314

The search function appears to be stripping off the hyphen and looking for verse #1315 instead of recognizing that I'm searching for verses 13-15.

It seems to handle comma-delimited sets of verses appropriately. It just doesn't handle hyphens correctly any more.

Re: "Search Scriptures" no longer recognizes hyphens in scripture reference

Posted: Sat Apr 14, 2018 8:32 am
by davesudweeks
I suggest you provide feedback on the LDS.org page where you are seeing the problem (there should be a feedback link at the bottom of the page). Posts here in this user-to-user forum will likely not make it to anyone with the ability to fix the problem. Posting here can be useful if someone else has a workaround for your problem, but almost all of us are just users like yourself. Feedback is read and distributed to the programmers (though there is no guarantee a feedback post will drive a change as they are an extremely small group and they don't set their own priorities).