Page 1 of 1

MLS 2.9 can't open old backups

Posted: Mon Sep 22, 2008 10:05 pm
by crislapi
You've got to love student wards. They provide so many unique challenges. Because of the high turnover, sometime things fall through the cracks. With the audits having just been done, we've identified a ton of outstanding checks. However, generally the students have moved on, there is no one left in the ward who knows them, and we can't contact them and find out the status of the check. However, most have cell phones, and those numbers don't change. They also have email addresses that are fairly stable. The challenge - their records are gone and we have no way of getting that info.

One particularly challenging issue is a check cut on 6 Jan 2007. What I tried to do tonight was restore a backup from Feb 2007. This would provide me the contact info for that member by restoring his membership to the database. However, I got an error along the lines of the backup format is not compatible with the current version of MLS.

Is there a way to get an older version of MLS? Any other thoughts? HQ won't give me the contact info because he is no longer in the stake. I haven't tried calling yet to see if there is a way to get MLS to open it. Thought I'd try here first.

FYI, I did a send/receive and then created a backup before trying to restore so that I could bring it back to the current status.

Posted: Mon Sep 22, 2008 10:20 pm
by aebrown
crislapi wrote:You've got to love student wards. They provide so many unique challenges. Because of the high turnover, sometime things fall through the cracks. With the audits having just been done, we've identified a ton of outstanding checks. However, generally the students have moved on, there is no one left in the ward who knows them, and we can't contact them and find out the status of the check. However, most have cell phones, and those numbers don't change. They also have email addresses that are fairly stable. The challenge - they're records are gone and we have no way of getting that info.

One particularly challenging issue is a check cut on 6 Jan 2007. What I tried to do tonight was restore a backup from Feb 2007. This would provide me the contact info for that member by restoring his membership to the database. However, I got an error along the lines of the backup format is not compatible with the current version of MLS.

Is there a way to get an older version of MLS? Any other thoughts? HQ won't give me the contact info because he is no longer in the stake. I haven't tried calling yet to see if there is a way to get MLS to open it. Thought I'd try here first.

FYI, I did a send/receive and then created a backup before trying to restore so that I could bring it back to the current status.


Right up to the release of MLS 2.9, there was an older install of MLS 2.7.3 on the mls.lds.org site in addition to the 2.8.x current version precisely so people could load older backups. For some inexplicable reason, that MLS 2.7.3 install link was removed when MLS 2.9 went live.

I have sent you by private message a way to get the MLS 2.7.3 installer. But in any case, I would recommend that the MLS team make this download available again, since MLS 2.8 and MLS 2.9 are unable to load older backups.

Posted: Mon Sep 22, 2008 11:39 pm
by crislapi
Alan_Brown wrote:I have sent you by private message a way to get the MLS 2.7.3 installer. But in any case, I would recommend that the MLS team make this download available again, since MLS 2.8 and MLS 2.9 are unable to load older backups.


Thanks Alan_Brown. It worked perfectly. I was able to get the contact info I needed and hope to have this check cleared up by Sunday. Couldn't have done it without you!

Where I foresee many others having this problem, I would also put in a plug for having older installers available for download again on mls.lds.org. I did check there first but 2.9 was all they have now.

Posted: Tue Sep 23, 2008 7:15 am
by childsdj
The MLS 2.7.3 installer was put out there only for the purpose of "patching" users from 2.6 and below versions of MLS. There was no automatic patch for any versions under 2.7.3. If users downloaded the MLS 2.7.3 they would automatically patch up to the current version on a send/receive.

I haven't heard of any issues of 2.9 not reading in old backups, but it is early.

If anyone else experiences this problem, please post it out on the forum. It could be data corruption with that backup or there could be a code issue in 2.9.

Posted: Tue Sep 23, 2008 9:48 pm
by lajackson
DJC wrote:I haven't heard of any issues of 2.9 not reading in old backups, but it is early.


MLS 2.9 will read in a 2.8 backup.

Posted: Mon Oct 20, 2008 11:58 am
by Wayne Roberts-p40
In our Stake we keep all of the previous MLS versions on a CD-ROM in the Stake office, just for the
purpose described in this thread.

Wayne
Calgary, Alberta, Canada