Switch MLS Language

Discussions around using and interfacing with the Church MLS program.
bbennion
New Member
Posts: 11
Joined: Sun Sep 18, 2011 6:09 pm

Postby bbennion » Wed May 02, 2012 7:07 am

Another bug I found was that pasting two files leaves an extraneous character at the end of the product.properties file. It hangs MLS such that MLS does not process the login credentials of any user.
Below is the product.properties file after the batch script was been applied. Note the funky character at the end, which turns to a space after I posted the file. That space confuses MLS.
#Wed May 02 06:57:30 PDT 2012
Migrator=0
DBBackups=20
SUL=0
MXLS=153600
Country=
BDB=0
Version=3.4.3_20496[95771]
Socket=43411
Variant=
PFI=0
Product=MLS
units=445851
MNLS=76800
MV2=0
FinEncoding=Cp1252
DBBackup=20
MPRS=30
PAF=0
DDW=0
EDB=0
LOGDEL=1
Language=en

russellhltn
Community Administrator
Posts: 26406
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Wed May 02, 2012 11:13 am

I seem to recall that's an artifact of using the + in the copy command. I think you can work around it by using the /b switch in the copy command.

copy /b mls1.tmp+mls2.tmp product.properties > nul
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

aetaber
New Member
Posts: 9
Joined: Tue Jan 31, 2012 6:58 pm

Postby aetaber » Thu May 24, 2012 4:28 pm

A related problem: I was setting up a computer for one of our Spanish branches and while I was able to change the language parameter from en to es, de, etc and save it successfully in a Win7 environment, when we run MLS it still displayes in English no matter what. And yes, MLS was not running while we were changing the file parameter. Please advise.

russellhltn
Community Administrator
Posts: 26406
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Thu May 24, 2012 4:55 pm

aetaber wrote:A related problem: I was setting up a computer for one of our Spanish branches and while I was able to change the language parameter from en to es, de, etc and save it successfully in a Win7 environment, when we run MLS it still displayes in English no matter what.


Where was the location of this file? I think it moves depending on XP or Win7. You might be editing a copy it doesn't look at.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

aetaber
New Member
Posts: 9
Joined: Tue Jan 31, 2012 6:58 pm

Postby aetaber » Mon May 28, 2012 7:03 pm

I hate to ask - but why would there be more than one properties file? Is that a known "feature"?

lajackson
Community Moderators
Posts: 8635
Joined: Mon Mar 17, 2008 9:27 pm
Location: US

Postby lajackson » Tue May 29, 2012 8:53 pm

aetaber wrote:I hate to ask - but why would there be more than one properties file? Is that a known "feature"?


XP and Win7 have different file system structures. MLS supports them both. I think rather than trying to figure out which operating system MLS is running on, it just parks some files in both places to become available for whichever operation system is running.

As Hook would say, well, nevermind. Not here. I think the programmers are doing the best they can under difficult circumstances.

russellhltn
Community Administrator
Posts: 26406
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Postby russellhltn » Tue May 29, 2012 8:58 pm

aetaber wrote:I hate to ask - but why would there be more than one properties file? Is that a known "feature"?


Not a "feature" that I'm aware of, but if the files where copied from an older computer, you might end up with a second set.

Once upon a time, the properties file was located under the C:\Program Files directory. But it was moved to make MLS compatible with Windows 7. I was thinking that under the right conditions, a copy could still be in the Program Files directory causing some confusion.

If you're making the recommended changes to the file and it's not causing the expect effect, then either you're not saving the changes, or MLS may be looking at a different file.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

marcporter
New Member
Posts: 32
Joined: Thu Feb 17, 2011 1:52 pm

Remove space from batch file

Postby marcporter » Wed Jun 06, 2012 7:19 pm

bbennion wrote:Another bug I found was that pasting two files leaves an extraneous character at the end of the product.properties file. It hangs MLS such that MLS does not process the login credentials of any user.
Below is the product.properties file after the batch script was been applied. Note the funky character at the end, which turns to a space after I posted the file. That space confuses MLS.



I found that I just had to remove the space from the batch file "=%1>" then it copied correctly. Here is the modified batch file file to work with the current location of the product.properties file in windows 7

@echo off
if "%1"=="en" goto :doit
if "%1"=="es" goto :doit
echo Usage: mlslang en (to change to English)
echo Usage: mlslang es (to change to Spanish)
goto :end
:doit
c:
cd \ProgramData\LDS Church\MLS\data
findstr /V "Language=" product.properties > mls1.tmp
echo Language=%1> mls2.tmp
copy mls1.tmp+mls2.tmp product.properties > nul
echo MLS language changed to %1
:end

celsohdz
New Member
Posts: 3
Joined: Tue Nov 20, 2012 12:00 pm
Location: Seville, Spain

Postby celsohdz » Tue Nov 20, 2012 12:45 pm

How am i suppose to make it work?

1 create 2 files one mlslang_en and another mlslang_es
2 leave the attributes for each language as shown ex.

@echo off
if "%1"=="en" goto :doit
if "%1"=="es" goto :doit
echo Usage: mlslang en (to change to English)
goto :end
:doit
c:
cd \ProgramData\LDS Church\MLS\data
findstr /V "Language=" product.properties > mls1.tmp
echo Language=%1> mls2.tmp
copy mls1.tmp+mls2.tmp product.properties > nul
echo MLS language changed to %1
:end

(for english)

and

@echo off
if "%1"=="en" goto :doit
if "%1"=="es" goto :doit
echo Usage: mlslang es (to change to Spanish)
goto :end
:doit
c:
cd \ProgramData\LDS Church\MLS\data
findstr /V "Language=" product.properties > mls1.tmp
echo Language=%1> mls2.tmp
copy mls1.tmp+mls2.tmp product.properties > nul
echo MLS language changed to %1
:end

(for spanish)


Is this right? Because I cannot make it work.

Help please brethren.

User avatar
aebrown
Community Administrator
Posts: 15100
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

Postby aebrown » Tue Nov 20, 2012 1:21 pm

celsohdz wrote:How am i suppose to make it work?


It looks like you are trying to follow the steps in this post. But those steps ask you to create a single file called mlslang.bat, and then you pass a parameter to it that is the two-letter language code. It looks like you copied the contents and simply changed the usage message to create two different files, instead of changing the actual code.

I still think the best approach is to make a single batch file, following the steps in the post I linked to.

Then you could create two different shortcuts, one of which runs "mlslang en" and the other runs "mlslang es". I don't see much point in creating two additional batch files, but if you want to do that, you would call one mlslang_en.bat which contains a single line "mlslang en" and the other is called mlslang_es.bat which contains a single line "mlslang es"
Questions that can benefit the larger community should be asked in a public forum, not a private message.


Return to “MLS Support, Help, and Feedback”

Who is online

Users browsing this forum: No registered users and 1 guest