Tech Forum "Topic Reply Notification" link doesn't work if not logged in

Having a problem with the Forum? Or feedback about the forum? This is the place.
BrianEdwards
Member
Posts: 64
Joined: Sun Oct 30, 2016 9:42 pm
Location: Michigan

Tech Forum "Topic Reply Notification" link doesn't work if not logged in

Postby BrianEdwards » Wed Aug 05, 2020 3:55 pm

[please move topic if there's a better forum location]

When I subscribe to a topic here on the Tech Forum and there's a response, I get an email with three links:
1) Newest post
2) Topic
3) Forum

If I'm not logged in, (2) and (3) work, but (1) sends me to a page with a friendly "FORBIDDEN" message. So I have to manually log into my church account, and then clicking the link sends me to the newest post.

I don't recall if this is something that has happened since the 2-step verification was put in place. And it could be that this behavior is out of Forum control, simply how the Church handles unauthorized access to its login-protected pages. But it would be convenient if the (1) link was routed automatically to the login page if needed, and then on to the Forum. Or at least if the "FORBIDDEN" page had a link for me to sign into my church account instead of forcing me to open up a new tab to do that.

I understand this may just be the way it works, and it's not the end-of-the-world. Just wanted to share to see if this was something that could be improved.

User avatar
TimRiker
Community Administrator
Posts: 220
Joined: Sun Dec 19, 2010 5:16 pm
Location: USA, Utah
Contact:

Re: Tech Forum "Topic Reply Notification" link doesn't work if not logged in

Postby TimRiker » Wed Aug 05, 2020 4:17 pm

The ideal would be to move Tech to OAuth2 and support 2FA there. I've not taken the time to do that. Joomla tracks the user data and group memberships based off LDAP calls. I've subscribed to this post. I'll look to see if I can find a way to work around it.

lajackson
Community Moderators
Posts: 9562
Joined: Mon Mar 17, 2008 9:27 pm
Location: US

Re: Tech Forum "Topic Reply Notification" link doesn't work if not logged in

Postby lajackson » Thu Aug 06, 2020 8:27 pm

BrianEdwards wrote:When I subscribe to a topic here on the Tech Forum and there's a response, I get an email with three links:
1) Newest post
2) Topic
3) Forum

If I'm not logged in, (2) and (3) work, but (1) sends me to a page with a friendly "FORBIDDEN" message.

I sent this problem as feedback to the GSC (Tim: GSC Case Number GSC05755466) and after several attempts they told me to contact the Church Accounts support team for help. I believe there is something in the last part of the (1) Newest post link that trips up the sign on system and will not let it redirect, whereas the shorter links 2 and 3 work.

I am still trying to find the right place at Church Accounts to obtain help.

The workaround is to click on the 2nd link which takes you to the topic and then scroll to the newest post. The default setting displays newest post last, so you would have to scroll through the entire topic to the last post. But I have my display set to show newest post first, so it is usually the first thing I see unless someone has posted again before I get there.

russellhltn
Community Administrator
Posts: 28757
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Tech Forum "Topic Reply Notification" link doesn't work if not logged in

Postby russellhltn » Thu Aug 06, 2020 8:53 pm

Based on Tim's posts, it seems the underlying issue is the forum is using an older method to authenticate. Not the sign-in screen itself, but the technology behind it. That may have to be resolved before any progress can be made on the complaint.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

lajackson
Community Moderators
Posts: 9562
Joined: Mon Mar 17, 2008 9:27 pm
Location: US

Re: Tech Forum "Topic Reply Notification" link doesn't work if not logged in

Postby lajackson » Sat Aug 08, 2020 7:01 pm

russellhltn wrote:Based on Tim's posts, it seems the underlying issue is the forum is using an older method to authenticate. Not the sign-in screen itself, but the technology behind it. That may have to be resolved before any progress can be made on the complaint.

Actually, I believe the problem is that the new sign on system chokes on the first link and rejects it, rather than redirecting to the sign on process. The second and third links cause a redirect to the new sign on system, and they then forward the now signed on user to the appropriate link. The first link should do exactly the same thing.

We just need to figure out what part of the first link is causing the new sign on system to choke. Maybe it is too long, maybe there is a character in it that causes problems. I am guessing the latter and that the character is the octothorpe. Or perhaps the question mark or ampersand.

What would I know. I am merely the frustrated user wondering why a Church link in a Church email does not work with a Church sign on system.

russellhltn
Community Administrator
Posts: 28757
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Tech Forum "Topic Reply Notification" link doesn't work if not logged in

Postby russellhltn » Sat Aug 08, 2020 7:19 pm

lajackson wrote:The second and third links cause a redirect to the new sign on system, and they then forward the now signed on user to the appropriate link.

Are you sure about that? As a public forum, you can go to topics and forums without logging in. But in order to see what's new, you have to be logged in so the forum knows what you've read.

If you want to have fun, open a new tab and go to Account Settings from the Church's main page. After logging in, come back to this tab and try to list new posts (or any other function that requires you to be logged in). In my case, I got the "Forbidden" page.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

lajackson
Community Moderators
Posts: 9562
Joined: Mon Mar 17, 2008 9:27 pm
Location: US

Re: Tech Forum "Topic Reply Notification" link doesn't work if not logged in

Postby lajackson » Sun Aug 09, 2020 12:40 pm

russellhltn wrote:
lajackson wrote:The second and third links cause a redirect to the new sign on system, and they then forward the now signed on user to the appropriate link.

Are you sure about that? As a public forum, you can go to topics and forums without logging in. But in order to see what's new, you have to be logged in so the forum knows what you've read.

If you want to have fun, open a new tab and go to Account Settings from the Church's main page. After logging in, come back to this tab and try to list new posts (or any other function that requires you to be logged in). In my case, I got the "Forbidden" page.

I am sure. You have to be signed on to access anything in the Moderator part of the Forum. I follow the Moderator Training & Chat and the Infractions threads. When I get the email with the three links and am not signed on, I can click on the 2nd or 3rd link in the emails. I am redirected to the sign on process, I sign on, and then I am taken to the Moderator page I had attempted.

When I click on the longer 1st link, it starts to take me to the sign on page, but eventually resolves to the Forbidden page.

I do not understand your suggested fun activity. I do not see the Forbidden page when I am already signed on. If I start at a signed out status, sign on through the Account Settings page, and then cannot get to a page requiring I be signed on, then I would suggest there is a bug and the Account Settings page is not properly setting the cookie.

I always come to the Forum through a bookmark to the Unread Posts link. This requires that I be signed on, of course, and I am dutifully redirected to the proper page where I have to remember to hit the enter key and not the tab key as my fingers were trained to do. Nevertheless, when I get the sign on process right, I then am taken to Unread Posts.

If I happen to remember to come to the Forum without signing on, I will try your fun suggestion and report back.

lajackson
Community Moderators
Posts: 9562
Joined: Mon Mar 17, 2008 9:27 pm
Location: US

Re: Tech Forum "Topic Reply Notification" link doesn't work if not logged in

Postby lajackson » Sun Aug 09, 2020 1:06 pm

lajackson wrote:If I start at a signed out status, sign on through the Account Settings page, and then cannot get to a page requiring I be signed on, then I would suggest there is a bug and the Account Settings page is not properly setting the cookie.

Okay, I did it. (What else is there to do right now? At least my laptop is immune from the virus that experts suggest will kill me (10% chance, due to my personal qualifications).

From a signed on state at the Forum, I signed out.

I went to the Account Settings page, and saw all of my personal information displayed. The page said I was still signed on. The page did not get the word that I had signed out.

From the Account Settings page I signed out. I then closed my browser (Firefox) and went elsewhere.

In a newly started browser, trying to access the Account Settings page I was taken to the Sign on process, participated in both steps, and once again saw my personal information.

I started a new tab and clicked on my Unread Posts link. It briefly appeared that you had me, but after some machinations taking much longer than usual, the sign on process decided I was already signed on and took me to the list of my unread posts.

I stand by my previous comment that various parts of the Church website system (not just Account Settings) do not recognize updates to the cookie from other parts of the site. I have not paid particular attention, but I often sign out, remember I wanted to do something else, and am able to do it without signing on again.

Perhaps it is a problem with the Forum itself. But when I sign out of the Forum and then try to get back in, I have to sign on again every time. If I accidentaly close my browser while at the Forum, I am signed out every time.

This is not true at other parts of the Church website system. I occasionally close my browser accidentally and am able to restart and go to the page requiring I be signed on as if I had never left. I have noticed other inconsistencies in the way parts of the website track my status. Signing out from some parts of the system do not necessarily sign me out from other parts of the system, unless I also close my browser.

Perhaps I should pay more attention. But I find that the path of least resistance serves me well, especially when it defaults to my advantage.

russellhltn
Community Administrator
Posts: 28757
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Tech Forum "Topic Reply Notification" link doesn't work if not logged in

Postby russellhltn » Sun Aug 09, 2020 1:20 pm

lajackson wrote:You have to be signed on to access anything in the Moderator part of the Forum.

Ah, that's different.


lajackson wrote:I do not understand your suggested fun activity.

I'm not able to duplicate it today. What happened to me is that I was writing a reply, but wanted to check something. So, I opened a new tab, went to the church main page, and selected "Account Settings". I was prompted to log in. I thought perhaps it was a security thing since I was now accessing my account information. So logged in again, did my research, went back my message, completed and attempted to post it - and got "Forbidden". At no point did I log out.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

lajackson
Community Moderators
Posts: 9562
Joined: Mon Mar 17, 2008 9:27 pm
Location: US

Re: Tech Forum "Topic Reply Notification" link doesn't work if not logged in

Postby lajackson » Sun Aug 09, 2020 1:23 pm

russellhltn wrote:At no point did I log out.

Perhaps you timed out?

I have noticed that when I am gone from the Forum for a long time (the length of which I cannot define), the Forum begins to miss me at some point and wants to make sure I know it knows I ignored it for a season, and signs me out.


Return to “Help with this forum”

Who is online

Users browsing this forum: No registered users and 1 guest