Windows Local Accounts not available

Discussions around the setup, operation, replacement, and disposal of clerk computers, not to include using MLS
russellhltn
Community Administrator
Posts: 29095
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Windows Local Accounts not available

Postby russellhltn » Wed Sep 16, 2020 6:57 pm

I think most of "my" computers have been configured to use a "username" rather than select form a list. Other members have noticed that they've had to add a .\ to the front of their name. As in ".\Clerk" or ".\Unit 12345". That forces the computer to look at the local account and not some domain.

SLC seems to have pushed out some kind of update that's causing this. It's been slowly going out over the past few weeks.

Do you have the option of "Other user"? If so, you should be able to enter a user name rather than being limited to a empty list. Once you get to where you can enter the name, you can add the .\ and make it work.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

drepouille
Senior Member
Posts: 2520
Joined: Sun Jul 01, 2007 5:06 pm
Location: Plattsmouth, NE
Contact:

Re: Windows Local Accounts not available

Postby drepouille » Thu Sep 17, 2020 5:43 am

I haven't tried adding a "./" prefix to the username yet. The "Other User" login asks for an email address or a telephone number. Since "./username" is neither, I haven't used it.

When I ran the management app last night, I did notice that some accounts have a "down arrow" icon, which I think indicates they are disabled. However, I don't remember if our four local accounts were marked as disabled. I need to look again.

When I configured this computer five years ago (when I was the STS), I created three local accounts. I think I set the passwords to never expire, and possibly not changeable by the user. It is entirely possible that all "never expire" passwords over a certain age have been disabled by a policy change. Again, i need to take a closer look at each account.

What is weird is that last night I created a new Clerk2 account, with a password, and set it as an Administrator. But it also does not appear on the Windows login screen. So perhaps this is more than just a disabled account or expired password problem.
Dana Repouille, Plattsmouth, Nebraska

russellhltn
Community Administrator
Posts: 29095
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Windows Local Accounts not available

Postby russellhltn » Thu Sep 17, 2020 10:13 am

drepouille wrote:I haven't tried adding a "./" prefix to the username yet.

It's ".\" - and only works when entering the name on a login screen. The "." means "This computer". The "\" indicates this is a "path" and not part of the name. So, ".\Clerk" mean "an account called "Clerk" located on THIS machine, not the "default" (which seems to be some kind of domain).

drepouille wrote:When I ran the management app last night, I did notice that some accounts have a "down arrow" icon, which I think indicates they are disabled.

Correct.

drepouille wrote:It is entirely possible that all "never expire" passwords over a certain age have been disabled by a policy change.

Not impossible, but I'd think that would take a custom script. I don't think it's something that can be done by "checkbox management"

drepouille wrote:What is weird is that last night I created a new Clerk2 account, with a password, and set it as an Administrator. But it also does not appear on the Windows login screen. So perhaps this is more than just a disabled account or expired password problem.

Right. They system has been set to default to "domain" accounts, not "local" ones.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

drepouille
Senior Member
Posts: 2520
Joined: Sun Jul 01, 2007 5:06 pm
Location: Plattsmouth, NE
Contact:

Re: Windows Local Accounts not available

Postby drepouille » Thu Sep 17, 2020 1:13 pm

drepouille wrote:I called the GSC, but they have never heard of this happening, and offered no solution.

I just called the GSC again. This time, I spoke with a brother who knew that "some" clerk computers had been joined to a Microsoft domain, so all local account usernames must be entered with the ".\" prefix. Also, the login screen will only display the last username to be used -- all other accounts will be hidden. So you must use the "Other user" option if you want to switch accounts.

This change came as a complete surprise to them, and they don't know how or why random clerk computers are being joined to the domain.
Dana Repouille, Plattsmouth, Nebraska

russellhltn
Community Administrator
Posts: 29095
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Windows Local Accounts not available

Postby russellhltn » Thu Sep 17, 2020 1:42 pm

drepouille wrote:Also, the login screen will only display the last username to be used -- all other accounts will be hidden. So you must use the "Other user" option if you want to switch accounts.

That's a pretty common Windows arrangement. Less common is when all local accounts are listed.

drepouille wrote:This change came as a complete surprise to them, and they don't know how or why random clerk computers are being joined to the domain.

I hope they figure it out. Given the domain, it has to be coming from their end. And in my case, it happened on a brand-new computer where I was the only person to log in. So, it's not like someone joined it to their private/work domain.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

russellhltn
Community Administrator
Posts: 29095
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Windows Local Accounts not available

Postby russellhltn » Thu Sep 17, 2020 2:30 pm

I'm hearing back that they think a change intended for "Workforce" has escaped.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

User avatar
Biggles
Senior Member
Posts: 1329
Joined: Tue May 27, 2008 4:14 am
Location: Watford, England

Re: Windows Local Accounts not available

Postby Biggles » Mon Oct 12, 2020 12:14 am

Has any resolution been forthcoming on this issue?

I noticed yesterday that my own clerk computer has come down with the local accounts missing from the login page. All the local accounts are still listed in the User’s section.

torriem
New Member
Posts: 1
Joined: Sun Jul 05, 2020 8:29 pm

Re: Windows Local Accounts not available

Postby torriem » Sat Oct 17, 2020 3:34 pm

Just had this happen on our clerk computer this week. Thank you to those who posted about the .\ username trick. We're back in but every application including MLS is gone now. Very strange.

russellhltn
Community Administrator
Posts: 29095
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Windows Local Accounts not available

Postby russellhltn » Sat Oct 17, 2020 3:40 pm

torriem wrote:We're back in but every application including MLS is gone now. Very strange.

Actually gone, or just the icons not appearing? Any possibility you went into a different account and just aren't seeing your usual desktop icons?
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

ulupoi
Member
Posts: 119
Joined: Mon Jan 24, 2011 2:21 am
Location: California, USA

Re: Windows Local Accounts not available

Postby ulupoi » Tue Oct 20, 2020 11:37 pm

The same thing has happened to all of the unit computers in our stake, that is, suddenly, only the Unit XXXXXX Windows User Account is visible as an available account. I think that a configuration setting meant for Church employee computers got pushed to unit computers by mistake. I found this simple solution. I tried it on a few of our computers and it's worked fine.

a. Click the start button and type "Edit Group Policy" and select the control panel option of that name.
b. In the left-hand pane, navigate to "Computer Configuration\Administrative Templates\System\Logon" .
c. Double click on "Enumerate local users on domain-joined computers" in the right hand pane.
d. Turn it on via the "Enabled" radio button.
e. Click "OK".
f. Check that "Hide entry points for Fast User Switching" is NOT enabled (it can be either enabled or not configured).
g. Close the Local Group Policy Editor.
h. Check that users are visible in the switch account menu and on the login page.
i. This answer comes from Heather Hamilton #17 on the Microsoft Community user forum website. https://answers.microsoft.com/en-us/win ... 180edf92f0

In addition, we have unit computers that are now demanding that the unit account password be changed every 42 days. I think that this is also due to a configuration setting meant for employee computers being pushed to unit computers by mistake. According to the GSC person I talked to, unit computer passwords are not supposed to expire. You can fix by doing the following. Either solution "a" or "b" alone might be enough, but it doesn't hurt to do both.

a. Change Group Policy setting.
1) Click the start button and type "Edit Group Policy" and select the control panel option of that name.
2) In the left-hand pane, navigate to "Computer Configuration\Windows Settings/Security Settings/Account Policies/Password Policy."
3) Double click on "Maximum password age" in the right hand pane.
4) In the popup window, set maximum password age to 0. Zero means that your password never expires.. Click "OK".

b. Change user account setting
1) Open Computer Management app. (Type Computer Management into Windows search bar.)
2) Go to Computer Management (Local)/System Tools/Local Users and Groups/Users
3) In the right pane, double-click on the problem account.
4) In the Properties pop-up window, check the box for “Password never expires.”


Return to “Clerk Computers”

Who is online

Users browsing this forum: No registered users and 2 guests