Page 2 of 3

Re: New Lenovo m710q Clerk Computer Provisioning Quirks

Posted: Fri Jul 20, 2018 3:19 am
by ulupoi
Thanks for the hints. They have been very useful. That UAC thing really saved me. I'm doing twelve computers, all Lenovo ThinkCentre M710q tiny desktops.

Here are some additional tips:

1. If you are preparing a computer that is going to used be used to run MLS in Korean, be aware that there is currently a problem that might make it impossible for MLS to display Korean characters unless you install the Korean language pack in Windows BEFORE Windows updates to most current version available on the Church's Windows Update Server. I just posted details in the MLS section of the forum. Basically, you have to stop Windows updates [Command Line (Admin) > net stop wuauserv], then install the Windows Korean language pack (from Settings with additional options in the Control Panel). These computers seem to be shipping with a rather old version of Windows 10, which might save you in this case. If you let Windows Updates proceed to completion before installing the Korean language pack, MLS will display all Korean characters as rectangles, and there is currently nothing you can do about it. The GSC is working on a solution.

2. At one point in the provisioning process, you will have to click a box, but your mouse will be frozen. If you Cntl-Alt-Del to the Task manager, your mouse will unfreeze.

3. On a couple of computers, I ran into frustrating Windows Update conflicts where a huge update or set of updates would load, then attempt to install, then fail, then unwind -- the whole process taking over an hour. This would happen repeatedly, in an endless cycle, like samsara or Groundhog Day. If you're stuck in such a loop, the solution is to boot into safe mode, open the Control Panel, and run the Windows Update Troubleshooter. Then restart the computer, and once it restarts, immediately stop the automatic update process by opening a Command Prompt (admin) window and entering net stop wuauserv so that the cycle doesn't repeat itself. (Don't worry, the Windows Update service will restart automatically when you reboot.) Then manually install the following Windows Updates in this order: KB4093120, KB4134659, KB4345420. Get these updates online from the official Microsoft Update Catalog. You might only have to install the first one (KB4093120) to break the logjam, after which Windows Update will install the rest automatically. If you are installing several computers, however, it can save you download time if you just download these once and copy them to each computer, because the first update is 1.3GB and the third is 0.8GB.

You can save yourself a lot of Windows Update trouble if, right after the provisioning process ends, you stop the Windows Update Automatic Update process (net stop wuauserv) and install those three updates manually. Depending on how fast your computer downloads Windows Updates in the background, your computer might reject the second or third of those manual updates. That's OK. At that point, just go back to the automatic update process. If it gets stuck, run the Windows Update Troubleshooter in Safe Mode again and keep going.

4. Adobe Reader XI is no longer supported by Adobe. It's not getting security updates, anymore. It's best to upgrade to Adobe Reader DC.

5. The image has an outdated version of MLS. Be sure to install the most recent version before you try to use it.

6. The pre-installed LibreOffice is old, too. The latest stable version is easily obtained from their website.

Re: New Lenovo m710q Clerk Computer Provisioning Quirks

Posted: Wed Jul 25, 2018 12:18 pm
by ulupoi
One more thing. If Sophos throws up weird errors on your new machine and you need to reinstall it, you have to uninstall it first, or it will carry old events logs and stuff into the new installation. Use the regular Windows uninstallation process. If that fails, reinstall right on top of it, and then try uninstalling again. That should work. Then reinstall again, and you should have a good, fresh installation of Sophos.

Re: New Lenovo m710q Clerk Computer Provisioning Quirks

Posted: Wed Jul 25, 2018 1:37 pm
by russellhltn
ulupoi wrote:you have to uninstall it first,

When I went down that path some years ago, I think I had to call support for files and/or a password to do it. Is it much simpler now?

Re: New Lenovo m710q Clerk Computer Provisioning Quirks

Posted: Wed Jul 25, 2018 3:25 pm
by ulupoi
Don’t need any special passwords anymore, thank goodness. Using the usual Windows uninstall pcrocess, uninstall all Sophos software. Here’s a list I got from GSC Support of what you might find, not all of which might be on your computer:

Sophos Patch Agent
Sophos Compliance Agent (NAC)
Sophos Network Threat Protection
Sophos System Protection
Sophos Client Firewall (SCF)
Sophos Anti-Virus (SAV)
Sophos Remote Management System (RMS)
Sophos Management Communication System (MCS)
Sophos AutoUpdate (SAU)
Sophos SafeGuard components
Sophos Health
Sophos Heartbeat
Sophos Endpoint Defense

Re: New Lenovo m710q Clerk Computer Provisioning Quirks

Posted: Wed Jul 25, 2018 4:44 pm
by ulupoi
Another quirk:

Out of the box, these M710q tiny desktops have a bug where if you switch to Wi-Fi and then back to wired Internet, your Ethernet connection is not recognized when you plug the cable back in. It will be recognized if you restart your computer. Running the Windows Internet troubleshooter doesn't help.

Installing the following BIOS and driver updates from the Lenovo support website fixes this bug, but I don't know whether all are necessary:

Update BIOS 26 Jun 2018.
Install drivers in this order.
Intel chipset firmware 26 Apr 2018
Intel chipset management engine 27 Jun 2018
LAN driver 27 Jun 2018

Re: New Lenovo m710q Clerk Computer Provisioning Quirks

Posted: Wed Aug 01, 2018 5:59 pm
by ulupoi
I've written up a detailed guide to setting up and installing the Lenovo M710q tiny desktops. If you want it, PM me and I'll send it to your email address in CDOL.

Re: New Lenovo m710q Clerk Computer Provisioning Quirks

Posted: Tue Aug 07, 2018 9:40 am
by BlairEsplin
jamiep39 wrote:I just replaced 5 of my clerk computers with the new Lenovo m710q (the super tiny ones) desktops. In doing so, I found some quirks to the LDS Provisioning profile and thought I'd write some annotations to the instructions for those setting up new clerk computers in the next few months, or at least while the image is the same.

If you follow along here: ... r?lang=eng (as of 3/3/2018. If the instructions, dated 8/22/2017, have changed, this post is likely irrelevant)

This is all under Step 2.

Section 7:
The Windows Post-install wizard screen that lets you choose what to install has a timeout of about 1 second. As soon as that screen comes up, immediately click on the text in the bottom left corner that says "Click here to stop the countdown" or something like that. You have to click on the text. Once that is paused, un-check the box next to LDSTheme. I think it's called that. Something about a theme and LDS. This program caused lots of issues on the two computers I set up before realizing how to prevent it from installing.

Once the computer actually starts provisioning, it'll run through a bunch of steps. One of the applications in the process will come up and ask you if you want to restart your computer. This is the application's installer, not the provisioning tool. If you say yes to that, your whole setup could be toast. (Note that I didn't actually say yes, but that's what I imagine would happen)

When the computer finishes installing and you can log in as the unit user, User Account Control will probably be in an awkward, broken state. (Probably from some broken registry entries) Try to open the Edge browser. If it says something about the local admin account can't open that, follow these steps:
1. Right click on the start button and open Control Panel
2. Click on User Accounts, and then User Accounts again
3. Click "Change User Account Control Settings"
4. Set the bar to the 3rd option from the bottom
5. Restart the computer
6. Repeat steps 1-3
7. Set the bar all the way to the bottom again
8. Restart the computer

The version of MLS that comes with the provisioning tool will be out of date. Before trying to launch MLS, go to and download the latest version. Once it's installed, I had to do the following to get it to run:
1. Right click on the shortcut
2. Go to Advanced
3. Check "Run as Administrator"
4. Apply the settings

The image I had also didn't install Sophos so I had to download it and install it from the MHTech site as well. Make sure to check to see if Sophos was installed.

Anyway, I hope these instructions help others who have to replace clerk computers any time soon. I just spent 4 hours replacing these and figured since I'd gone through all the work already, I might as well post some instructions.

Good luck!

This is probably the problem I’ve had with setup of my last two computers. Your workaround got the one I set up yesterday going.

Last fall I attempted to set up one of these computers and when finished the windows programs such as edge would not open, giving the error message you spoke of. MLS worked fine however. I adjusted the settings as you said but then while I was able to access windows programs I was locked out of MLS. I did not know about running it as administrator.

I spent hours on the phone with the global service center over a period of weeks, never getting a solution to the problem. Finally in June I gave up on it and contacted the FM group who took it back with the intention of sending it back to Salt Lake for replacement. However Salt Lake told the fm group that they had to fix it. A sister at the fm group has been working with it when she has time for about a month now. She has contacted people pretty high up in the computer department and the only solution she was given was to totally reprogram the computer. She has not yet got it working and has told me that she’s not going to do anything more with it and that if they want it fixed they are going to have to do it themselves.

I tell you this to demonstrate the fact that Salt Lake hasn’t got a clue about this problem and that perhaps smart tech people such as yourselves should contact Salt Lake and discuss this problem with them since they don’t seem to know the problem exists and don’t have a solution or workaround for it.

In so thankful that I found this post or I’d have another non functional computer that I’d be spending countless hours trying to get to work.

I told the manager that the FM group sister is working with that the better solution would have been to accidentally run over the computer with a car and throw it into the dumpster since the computer is not worth the amount of time that I and the other tech people from my stake and the lady at the FM group have put into it.

Re: New Lenovo m710q Clerk Computer Provisioning Quirks

Posted: Tue Aug 07, 2018 12:13 pm
by ulupoi
One of the GSC people who helped me last month said that there is an option for starting the whole thing from scratch. They send you over to a Microsoft site to reinstall Windows, and you get the provisioning software from them, or something like that. That might be your best bet for that one computer that is currently in the hands of your FM Group. I'll send my notes to you in a minute.

Re: New Lenovo m710q Clerk Computer Provisioning Quirks

Posted: Tue Aug 07, 2018 12:18 pm
by ulupoi
HP LaserJet 1300
If you need to install an HP LaserJet 1300 (or 1320) on a new unit computer (Windows 10), Windows will no longer install it correctly, automatically. Instead, install it manually following these steps:

a) Go to the HP support site for the 1300 (or 1320) ( ... ies/238320).
b) Download and install the Dot4 driver.
c) Install the printer selecting the manual install option. Go to Settings > Devices > Printers and Scanners. Click on "Add printer or scanner." Wait several seconds, and this option will appear: "The printer that I want isn't listed." Click on that. A new, "Add printer" window will open.
d) Select the option: Add a local printer or network printer with manual options. Click: Next.
e) From the "Use an existing port" menu, select the Dot4 port that you just installed.
f) The next window is for driver selection. Click on the Windows Update button to get more driver options. It will seem like it's stuck, but it's not. It just takes an inordinately long time for the drivers to load. Just wait for it. When the additional drivers load, select HP LaserJet 1300 PCL5 (or HP LaserJet 1320 PCL5). This seems to be the best driver for this old printer. The HP Universal Printer Driver causes problems when printing images or PDFs.

HP LaserJet 1200
I haven't been able to get it to work with any computer running Windows 10 64-bit version 1709 (last year's Fall Creators Update) or later. This printer works fine with Linux Mint XFCE, though. In Linux, install HPLIP from Software Manager (if it is not already installed) and also install the HPLIP gui. Then run Menu > All > HPLIP Toolbox. Use it to set up the printer. An HP Icon is added to the panel, and you can also launch HP Device Manager from there.

Re: New Lenovo m710q Clerk Computer Provisioning Quirks

Posted: Tue Aug 07, 2018 12:28 pm
by russellhltn
ulupoi wrote:HP LaserJet 1200
I haven't been able to get it to work with any computer running Windows 10 64-bit version 1709 (last year's Fall Creators Update) or later.

I did find this link, but I don't know of that will work.

That's a pretty old model. Perhaps 15+ years. It might be time to retire it.