LDS.org not working inside firewall

Discussions about Internet service providers (ISPs), the Meetinghouse Firewall, wired and wireless networking, usage, management, and support of Meetinghouse Internet
rickk
Member
Posts: 125
Joined: Fri Aug 19, 2011 10:13 am
Location: Ridgefield, WA, USA

Re: LDS.org not working inside firewall

Postby rickk » Mon Jan 19, 2015 12:41 pm

And as I said, we have 2 buildings with comcast and one of them was fine yesterday (at least that was the report from some of the other tech clerks - I didn't try it myself). Also, the stake center has been fine with comcast for months with the latest config and this only happened in the past couple of weeks.

Comcast isn't blocking our DNS servers since lots of other sites do work - even lds.org sites like cdol.lds.org and tech.lds.org. It just seems to be the main church website that has the issues. So it doesn't seem like a basic connectivity issue, it is something specific to http://www.lds.org.

I tried calling the GSC but it says they are closed for the holiday. I will try again tomorrow.

russellhltn
Community Administrator
Posts: 26625
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: LDS.org not working inside firewall

Postby russellhltn » Mon Jan 19, 2015 1:36 pm

rickk wrote:And as I said, we have 2 buildings with comcast and one of them was fine yesterday (at least that was the report from some of the other tech clerks - I didn't try it myself). Also, the stake center has been fine with comcast for months with the latest config and this only happened in the past couple of weeks.


For kicks and grins, try ping "www.lds.org" from both places - see what IP you get. Also check to see if the VPN light is on at the sites that don't work.

Also do a ipconfig /all and see what the DNS is reported as.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

rickk
Member
Posts: 125
Joined: Fri Aug 19, 2011 10:13 am
Location: Ridgefield, WA, USA

Re: LDS.org not working inside firewall

Postby rickk » Mon Jan 19, 2015 3:15 pm

I was on a Mac (and an iPad) yesterday and the DNS servers were the ones listed in another thread in the forum as the only approved servers (8.34.34.92 and 8.35.35.92). I can run a ping or an nslookup/dig to see what IP is getting returned. It is interesting that the browser is not showing "looking up www.lds.org" like it will when having DNS problems. It says "connecting to www.lds.org" so it seems like the DNS has returned an IP address and it is trying to connect...

russellhltn
Community Administrator
Posts: 26625
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: LDS.org not working inside firewall

Postby russellhltn » Mon Jan 19, 2015 4:19 pm

rickk wrote:It says "connecting to http://www.lds.org" so it seems like the DNS has returned an IP address and it is trying to connect...


The question then becomes: is it the right IP address for inside the firewall?

Now, the interesting thing is at home if I go to "lds.org" it becomes "www.lds.org". But lds.org resolves to 216.49.176.33. http://www.lds.org becomes "e5298.g.akamaiedge.net - 23.203.57.80.

My home client has the DNS set to the home router, and it's set for Google (8.8.8.8)
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

rickk
Member
Posts: 125
Joined: Fri Aug 19, 2011 10:13 am
Location: Ridgefield, WA, USA

Re: LDS.org not working inside firewall

Postby rickk » Mon Jan 19, 2015 4:43 pm

That was interesting. I did an nslookup for a few sites both inside the firewall and at home and I sometimes get the same answer and sometimes not...

<site> - <inside FW> - <Home> - <Name>
www.lds.org - 23.203.225.116 - 23.200.95.116 - e5398.g.akamaiedge.net
www.foxnews.com - 23.61.194.193 - 165.254.247.201 - a20.g.akamai.net
cdol.lds.org - 216.49.178.28 - 216.49.178.28 - cdol.lds.org

It also looks like the IP address moves around (even at home) if I do multiple lookups spread out over time. I suppose this is not unreasonable if you have a number of servers and they are trying to load balance. I'm not sure how the DNS servers deal with this though. That is in the black magic category for me. :)

russellhltn
Community Administrator
Posts: 26625
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: LDS.org not working inside firewall

Postby russellhltn » Mon Jan 19, 2015 4:48 pm

Akamai is one of the major Internet backbone sites. It's not suprising that the main lds.org page uses them, and that they might have multiple IP addresses. What I find really odd is the foxnews link where it's 23.x.x.x inside the firewall and 216.x.x.x at home. Very different IP.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

rickk
Member
Posts: 125
Joined: Fri Aug 19, 2011 10:13 am
Location: Ridgefield, WA, USA

Re: LDS.org not working inside firewall

Postby rickk » Mon Jan 19, 2015 5:01 pm

russellhltn wrote:What I find really odd is the foxnews link where it's 23.x.x.x inside the firewall and 216.x.x.x at home.


Yeah - I thought that too. It is possible that was caused by the VPN software that I use (I work at home). I tried it again and got 23.62.7.9 - which makes way more sense.

However if www.lds.org and www.foxnews.com are both being served by akamai, why does foxnews consistently work inside the firewall and www.lds.org not?

russellhltn
Community Administrator
Posts: 26625
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: LDS.org not working inside firewall

Postby russellhltn » Mon Jan 19, 2015 5:18 pm

It's the main site that doesn't work? Not something else?
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

rickk
Member
Posts: 125
Joined: Fri Aug 19, 2011 10:13 am
Location: Ridgefield, WA, USA

Re: LDS.org not working inside firewall

Postby rickk » Mon Jan 19, 2015 5:30 pm

russellhltn wrote:It's the main site that doesn't work? Not something else?


Yup. www.lds.org sits and spins the wait cursor and then times out with "Server quit responding". Other sites like cdol.lds.org and facebook and foxnews all work just fine.

russellhltn
Community Administrator
Posts: 26625
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: LDS.org not working inside firewall

Postby russellhltn » Mon Jan 19, 2015 5:37 pm

rickk wrote:Yup. http://www.lds.org sits and spins the wait cursor and then times out with "Server quit responding".


Which in turn loads scripts and things from other sites. So the problem may be the DNS lookup of the "contributors".
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.


Return to “Meetinghouse Internet”

Who is online

Users browsing this forum: No registered users and 1 guest