lds.org/lcr doesn't work with Chrome

Discussions about the Leader and Clerk Resources on lds.org.
trohlfing
New Member
Posts: 24
Joined: Mon Aug 20, 2012 10:16 am

lds.org/lcr doesn't work with Chrome

#1

Post by trohlfing »

I am the ward clerk, using lds.org/lcr. As of this morning I can't get any of the dropdown menus (like Membership, Organizations, Reports, etc.) to work. Click on them, nothing happens. It does the same thing on my home computer (Win7/Chrome), and at the church (XP/Chrome). They work on Firefox. Any suggestions?
aclawson
Senior Member
Posts: 760
Joined: Fri Jan 19, 2007 6:28 pm

Re: lds.org/lcr doesn't work with Chrome

#2

Post by aclawson »

Not all websites work equally well with all browsers - the ultimate answer may be to just use Firefox.

That said, you may have an extension that is causing problems. Turn off all of the extensions and attempt to use the site. If it works, then go through one at a time until you find an extension that causes the problem to reappear.
trohlfing
New Member
Posts: 24
Joined: Mon Aug 20, 2012 10:16 am

Re: lds.org/lcr doesn't work with Chrome

#3

Post by trohlfing »

I turned off all the extensions, and it still doesn't work. I'm pretty sure it used to work with Chrome. Don't know if lds.org changed, or if Chrome has had an update. Could also be a Windows update thing, since I did a big Windows update yesterday. Also, it's odd that the problem exists both at my home (W7), and at the church (XP), with different browser extensions, etc. Are you aware of other people who use Chrome successfully for lds.org/lcr? I think your recent support message actually recommended that people who are on XP at the church should use Chrome when lds.org transitions away from MLS to the website.
jdlessley
Community Moderators
Posts: 8779
Joined: Mon Mar 17, 2008 12:30 am
Location: USA, TX

Re: lds.org/lcr doesn't work with Chrome

#4

Post by jdlessley »

See this thread and this thread. In short, try Ctrl+F5.
JD Lessley
Have you tried finding your answer on the ChurchofJesusChrist.org Help Center?
trohlfing
New Member
Posts: 24
Joined: Mon Aug 20, 2012 10:16 am

Re: lds.org/lcr doesn't work with Chrome

#5

Post by trohlfing »

Ctrl+F5 was the magic trick. Thanks!
norgaards
New Member
Posts: 11
Joined: Tue Sep 13, 2011 9:35 pm
Location: Denmark

Re: lds.org/lcr doesn't work with Chrome

#6

Post by norgaards »

I'm having the same problem logging into LCR with Chrome . It helps flushing the dns but then it starts again. I'm only able to log in a single time after having flushed the dns, then I have to do it again. I have no problem logging into other parts of LDS.org, my notes, or familysearch. Neither do I experience any problems loggin into any other website on the web - it is only when loggin into LCR. Wish that this problem could be fixed as I am used to Chrome and would like to continue using it.

John
wwoodford
New Member
Posts: 37
Joined: Fri Jan 19, 2007 3:02 pm
Location: Fayetteville, NC

Re: lds.org/lcr doesn't work with Chrome

#7

Post by wwoodford »

I use Chrome almost exclusively (to include on Windows 10, two different Chrome books, Android tablet and Android phone) and I have no difficulty accessing LCR. I access LCR at least once a day, normally several times per day.

William Woodford
norgaards
New Member
Posts: 11
Joined: Tue Sep 13, 2011 9:35 pm
Location: Denmark

Re: lds.org/lcr doesn't work with Chrome

#8

Post by norgaards »

That's strange - I've tried to reinstall Chrome, but to no avail. I'm using windows 10 as well. Anyway there is some kind of dns issue. Each time I flush the dns I'm afterwards able to log in one time without problems, then the problem continues and I have to flush dns again. I've accessed LCR with Chrome without problems for years, then it the problem started suddenly.

John
norgaards
New Member
Posts: 11
Joined: Tue Sep 13, 2011 9:35 pm
Location: Denmark

Re: lds.org/lcr doesn't work with Chrome

#9

Post by norgaards »

I tried deleting cookies and other website date through settings in Chrome. The next time I successfully logged in to LCR, but when I try logging in again it continues returning the http error 400.

John
lajackson
Community Moderators
Posts: 10419
Joined: Mon Mar 17, 2008 10:27 pm
Location: US

Re: lds.org/lcr doesn't work with Chrome

#10

Post by lajackson »

Please use feedback to send these specific comments to the developers. With some of these details, they may be able to solve the problem.

This is a user-to-user forum, and your comments are appreciated here to help others work around these problems. But the developers do not normally frequent the Forum. Feedback is the certain way to let them know what you are seeing.
Post Reply

Return to “Leader and Clerk Resources”