Cannot Show Content Because “English” is Not Installed

Any discussions around the Gospel Library App on various mobile and electronic devices.
genman
Member
Posts: 144
Joined: Wed Feb 08, 2012 4:51 pm
Location: US

Re: Cannot Show Content Because “English” is Not Installed

#21

Post by genman »

lajackson wrote: Fri Jan 13, 2023 4:16 pm When this happens to me I go to the Language setting and select English. The error goes away. One time several years ago I had to select a different language, and then English again to get rid of the error.
How do you "go to the Language setting and select English"? I can't find the Language settings on the app. Maybe it didn't install enough to get to the point to be able to even have Language setting option that I can get to?

Any help would be appreciated.
lajackson
Community Moderators
Posts: 11027
Joined: Mon Mar 17, 2008 10:27 pm
Location: US

Re: Cannot Show Content Because “English” is Not Installed

#22

Post by lajackson »

genman wrote: Tue Jan 17, 2023 8:50 pm I can't find the Language settings on the app.
On my Android device, the three-dot menu at the top right of the Library page has several links that are not included on the Home page. One of them is Language.

Select Library, then the three-dot menu at the top right. One of the options will be Language. Sometime selecting English again solves the problem for me. Other times, I select another language, then select English again.
genman
Member
Posts: 144
Joined: Wed Feb 08, 2012 4:51 pm
Location: US

Re: Cannot Show Content Because “English” is Not Installed

#23

Post by genman »

lajackson wrote: Wed Jan 18, 2023 9:21 am
genman wrote: Tue Jan 17, 2023 8:50 pm I can't find the Language settings on the app.
On my Android device, the three-dot menu at the top right of the Library page has several links that are not included on the Home page. One of them is Language. ...
Are you talking about within the Gospel Library App? Or are you referring to the Gospel Library page on the website? Assuming you are talking about the Gospel Library App, when I press the Library icon at the bottom of the Home screen, nothing happens. So I can't even get to the Library to try tapping the three-dot menu.
lajackson
Community Moderators
Posts: 11027
Joined: Mon Mar 17, 2008 10:27 pm
Location: US

Re: Cannot Show Content Because “English” is Not Installed

#24

Post by lajackson »

genman wrote: Wed Jan 18, 2023 1:53 pm . . . when I press the Library icon at the bottom of the Home screen, nothing happens. So I can't even get to the Library to try tapping the three-dot menu.
Yes, in the app. If you cannot select the Library icon, I would guess that you do not have any content at all.

Solving that often included uninstalling and installing again, making sure you have a good Internet connection. Other posts have suggestions to help solve that problem.
genman
Member
Posts: 144
Joined: Wed Feb 08, 2012 4:51 pm
Location: US

Re: Cannot Show Content Because “English” is Not Installed

#25

Post by genman »

lajackson wrote: Wed Jan 18, 2023 8:03 pm
genman wrote: Wed Jan 18, 2023 1:53 pm . . . when I press the Library icon at the bottom of the Home screen, nothing happens. So I can't even get to the Library to try tapping the three-dot menu.
...uninstalling and installing again, making sure you have a good Internet connection...
I have uninstalled and installed many times, and does the same. I can get to other sites and even download the app using the good internet connection. It is something systemic, not on my end, since others have recently been having similar problems with GL version 6.3.1 on Android regarding failed load of English over and over again. My only hope in the near term is that there is a workaround to the bug, other than just permanently uninstalling Gospel Library.
davesudweeks
Senior Member
Posts: 2456
Joined: Sun May 09, 2010 9:16 pm
Location: Oklahoma, USA

Re: Cannot Show Content Because “English” is Not Installed

#26

Post by davesudweeks »

I am also on android, GL version 6.3.1 and have no problems that I can see. If you haven't yet, I recommend you submit in-app feedback (from the Home screen: 3-dots menu - Help - Send Feedback). You shouldn't have to "go into the library" to get to the feedback link. I believe that feedback will provide developers the OS information from your device so they can try to figure out what is going on.
User avatar
sbradshaw
Community Moderators
Posts: 5923
Joined: Mon Sep 26, 2011 9:42 pm
Location: Utah
Contact:

Re: Cannot Show Content Because “English” is Not Installed

#27

Post by sbradshaw »

I wonder if you're able to access content in other languages in the app – is the problem just with English content?
For example, this link should open to 1 Nephi 1 in Spanish, downloading the Spanish catalog if it's not installed:
https://www.churchofjesuschrist.org/study/scriptures/bofm/1-ne/1?lang=spa

I think it would also be worth trying on another network, if you haven't already. Even if you have a good internet connection, there might be something in your network or in your internet service provider's configuration that's blocking the Church content servers, but allowing traffic through to the main Church website, the Google Play Store, etc.

Are you able to get to this URL in a browser?
https://ips-cdn-edge.churchofjesuschrist.org/content/production/v4/languages/eng/index.json
Samuel Bradshaw • If you desire to serve God, you are called to the work.
genman
Member
Posts: 144
Joined: Wed Feb 08, 2012 4:51 pm
Location: US

Re: Cannot Show Content Because “English” is Not Installed

#28

Post by genman »

When I try again today, Android Gospel Library is working. When I look under GL > Help > What's New, it shows the version as 6.3.0 now. So apparently the software folks heard about the problems with 6.3.1 and rolled it back. It's working now.

Those of you who had 6.3.1 Android and who it was working for, I bet would have seen a problem if you completely uninstalled and reinstalled. Who knows. At least they rolled back the buggy release.

Thank you to those who replied.
User avatar
sbradshaw
Community Moderators
Posts: 5923
Joined: Mon Sep 26, 2011 9:42 pm
Location: Utah
Contact:

Re: Cannot Show Content Because “English” is Not Installed

#29

Post by sbradshaw »

genman wrote: Sat Jan 21, 2023 12:04 pm When I try again today, Android Gospel Library is working. When I look under GL > Help > What's New, it shows the version as 6.3.0 now. So apparently the software folks heard about the problems with 6.3.1 and rolled it back. It's working now.
What's New has information about major new features that are added to the app – it doesn't have content for every app update. You can see the app version you have installed under Settings > App Details. Gospel Library 6.3.1 for Android was released on November 1st, and it's still the current latest version on the Google Play Store.

It's possible there was a temporary problem on the content servers, but I'm not sure why it would only have affected some users.

I'm glad it's working for you now!
Samuel Bradshaw • If you desire to serve God, you are called to the work.
genman
Member
Posts: 144
Joined: Wed Feb 08, 2012 4:51 pm
Location: US

Re: Cannot Show Content Because “English” is Not Installed

#30

Post by genman »

sbradshaw wrote: Sat Jan 21, 2023 3:00 pm You can see the app version you have installed under Settings > App Details. Gospel Library 6.3.1 for Android was released on November 1st, and it's still the current latest version on the Google Play Store.
It's possible there was a temporary problem on the content servers, but I'm not sure why it would only have affected some users.
I'm glad it's working for you now!
I see. Yes I do have version 6.3.1 installed then. I'm not sure why it started working. The last thing I tried before it started working was going to the the following Spanish language link from a browser, similar to what you suggested:

https://www.churchofjesuschrist.org/study/lib?lang=spa

When I did that, instead of bringing up the Gospel Library app like I thought it was supposed, it brought it up in the browser. So I figured it didn't do anything. Maybe that workaround worked after all. Or maybe it starting to work then was a coincidence.
Post Reply

Return to “Gospel Library”