Workaround to fix calendar sync problems

Discussions about the Calendar Tool at lds.org. Questions about the calendar on the classic site should be posted in the LUWS forum.
lonniereeder
New Member
Posts: 2
Joined: Sun May 01, 2011 2:32 pm
Contact:

#141

Post by lonniereeder »

samliddicott wrote:[Editor's Note from aebrown: This topic seems sufficiently valuable to the community that I moved this post and its responses into a new thread from their original location in the Calendar sync issues thread.]

Fixed for me! I speculated that it was to do with HTTPS wildcard certficates and google (the *.lds.org) issue.
So I wrote a wrapper handler which is at https://mail.liddicott.com/ldscalendar.php/ - which anyone can use.

if your calendar id is 123456, then you can sync to the URL https://mail.liddicott.com/ldscalendar.php/123456
If I forget to renew my ssl certificate it may stop working, but you can also use http instead of https

This works and imports "instantly" for me.

Also, you can add any junk you like after your number (precede junk by a slash) e.g.:
https://mail.liddicott.com/ldscalendar. ... 6/test.ics

means your browser will try and save a file called "test.ics" - you can stick any fake-filename you like on the end.

perhaps there is enough of a clue here (that this works) that the developers can fix the problem.

In case anyone wants to run their own wrapper, the php code is here listed on the page - it is very quick and dirty, but it's years since I did php.

Changes: add the church's no-cache tags to avoid search engines and so forth. Also added robots.txt to my site.


This worked perfectly for me... I added the calendar, it populated on Google, then my Droid updated just fine. Thanks so much for the assist.
togiles
New Member
Posts: 15
Joined: Fri Aug 22, 2008 9:41 am
Location: Beijing, China
Contact:

#142

Post by togiles »

Is this a problem / bug on google itself, or on lds.org? Who is working the issue? I'd be interested in helping getting this resolved if there is a need. Can someone write up the specifics of the issue - and I can get a bug submitted to google, and depending on the issue - maybe even spend some personal time on the fix. -Todd
User avatar
aebrown
Community Administrator
Posts: 15138
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

#143

Post by aebrown »

togiles wrote:Is this a problem / bug on google itself, or on lds.org? Who is working the issue?
All I know for sure is that the Calendar Sync page used to provide a URL that was labeled as being intended for syncing with Google Calendar; now the bottom of the Calendar Sync page says:
To one-way sync your Church calendar to your Google calendar:

Temporarily unavailable - we're working with Google to fix this
"We" clearly means the Church's calendar development team. "Working with Google" could mean that we're helping Google find and fix their problem, or Google is helping us find and fix our problem, or a combination of the two. Your guess is as good as mine.
togiles wrote:I'd be interested in helping getting this resolved if there is a need. Can someone write up the specifics of the issue - and I can get a bug submitted to google, and depending on the issue - maybe even spend some personal time on the fix.
You can sift through this thread (and the related Calendar sync issues thread) and find a variety of reports. But I would warn you that the experience is not entirely consistent for all users.
Questions that can benefit the larger community should be asked in a public forum, not a private message.
togiles
New Member
Posts: 15
Joined: Fri Aug 22, 2008 9:41 am
Location: Beijing, China
Contact:

#144

Post by togiles »

aebrown wrote: "We" clearly means the Church's calendar development team. "Working with Google" could mean that we're helping Google find and fix their problem, or Google is helping us find and fix our problem, or a combination of the two. Your guess is as good as mine.
How would I go about contacting the calendar development team. While I do not specifically work on Google Calendar, I do work at Google and would be glad to provide whatever help I could in my spare time to help get this resolved.
russellhltn
Community Administrator
Posts: 32115
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

#145

Post by russellhltn »

I've forwarded your offer.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
russellhltn
Community Administrator
Posts: 32115
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

#146

Post by russellhltn »

Has something changed in the workaround? It's no longer working for me. And apparently hasn't been for several days - maybe longer.

I tried the URL I used in my Google Calendar and it starts to download but then switches to "Unable to download". My ward has added a bunch of calendars and events, so it's possible that some strange data has been introduced that's affecting things.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
User avatar
samliddicott
Member
Posts: 77
Joined: Wed May 20, 2009 9:48 am
Location: England

#147

Post by samliddicott »

RussellHltn wrote:Has something changed in the workaround? It's no longer working for me. And apparently hasn't been for several days - maybe longer.

I tried the URL I used in my Google Calendar and it starts to download but then switches to "Unable to download". My ward has added a bunch of calendars and events, so it's possible that some strange data has been introduced that's affecting things.

I tried just now and it works for me. Please send me a private message with your calendar ID and I'll look into what problems you may have.
russellhltn
Community Administrator
Posts: 32115
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

#148

Post by russellhltn »

I played with it a bit more just now and found it was because I was using "https" to your site. When I dropped back to just "http" it started working.

Thanks.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
russellhltn
Community Administrator
Posts: 32115
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

#149

Post by russellhltn »

samliddicott wrote:I suppose that google does some kind of caching magic which helps it decide not to bother trying again.

A solution which has worked is to make use of the flexibility of the wrapper, for example, if your work-around wrapper was:
https://mail.liddicott.com/ldscalendar.php/987654321
and this is not working, then try:
https://mail.liddicott.com/ldscalendar. ... lendar.ics
You can make up any file name you like on the end, and it will still work.

This does not seem to be working for me. If I try the second URL with my own filename (lds.ics), it doesn't work. But if I try the first URL, it works. THEN if I try the original URL, it works. If I close the browser session, I can repeat this.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
User avatar
samliddicott
Member
Posts: 77
Joined: Wed May 20, 2009 9:48 am
Location: England

#150

Post by samliddicott »

RussellHltn wrote:This does not seem to be working for me. If I try the second URL with my own filename (lds.ics), it doesn't work. But if I try the first URL, it works. THEN if I try the original URL, it works. If I close the browser session, I can repeat this.

This seems highly weird, as my code (plain for all to see) does nothing session based in relation to this at all. I believe you but I have no idea.
Post Reply

Return to “Calendar”