Error during file creation

Discussions around using and interfacing with the Church MLS program.
Post Reply
New Member
Posts: 4
Joined: Fri Oct 07, 2011 11:38 pm

Error during file creation


Post by brentp »

A Ward in our Stake is getting the following error, I am just waiting on more details for when it happens, but in the meantime has anyone come across this error

The Error Window is - Error during file creation
An error occurred while creating the data file. Contact your stake clerk for assistance. The stake clerk should contact support if he needs assistance to resolve this problem.


MLS.JPG (27.98 KiB) Viewed 789 times
New Member
Posts: 36
Joined: Wed Sep 30, 2009 11:55 am
Location: Orem, UT - USA


Post by MerrillDL »

From my experience, this error sounds like it may be the result of Windows not being able to create a file. You didn't say what you were trying to do when the error occurred? Were you doing a data backup of MLS? Has this specific operation worked in the past on this computer? What changed on the computer in the time that it worked to the time it stopped working.

Basically, the Windows operating system is reporting back to MLS that it was not able to write a new file to the hard drive or other storage location. For troubleshooting, I would look at the reasons why Windows cannot create a file.

If you backup to external storage, it could be write protected. If you backup to the hard drive, there could be a number of causes.

I think there are only two primary reasons why a file cannot be created.

User Permissions and/or File System (FAT32 or NTFS) parameters have been exceeded

Does the logged in user (should be 'Clerk') have administrator rights on the workstation?

Try creating a new folder and set the MLS backup path to the new folder. Make sure the folder name is short and the path to the folder is also short; i.e., c:\mls-data\.

I'd be interested to hear how this is resolved.
New Member
Posts: 4
Joined: Fri Oct 07, 2011 11:38 pm


Post by brentp »

For those interested.

Due to the age of the computer I decided to reload the OS and start with a fresh copy of MLS.

After restoring the backup the error still existed.

In the end I called the GSD, what I found out is the backups were corrupted.
So I deleted the MLS data folder from C:\Documents and settings\All Users\LDS Church\**Unit**
Then Launched MLS and configured the locl unit info again.
I then had to go through each of the backup and test Send/Recieve unit I found a working backup. In my case the last working backup was from February.

So MLS is now up and running and can submit.

As the last few months of MLS data is missing, I was told to contact my local Service Center and request a Setup File for the local unit.
Once this is done from MLS I have to click File - Request Unit Refresh Data
Then File - Check Membership Records (This isnt in the file menu, so I am guessing this might be 'Membership Record Transaction Report'

Once this has been done, it should pull down the missing financial and membership records.

I'll have to wait till my local service center open to finish it off.

Community Administrator
Posts: 31948
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.


Post by russellhltn »

I believe that CHQ takes a backup every 30 days. But if you have to use a backup, you should contact support.
Have you searched the Help Center? Try doing a Google search and adding "" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
Post Reply

Return to “MLS Support, Help, and Feedback”