Page 1 of 1

Loss of Geocode functionality

Posted: Sat Jul 14, 2012 2:59 pm
by ffrsqpilot
We just ran into a problem with creating custom reports when one of the criteria used to create the report includes a geocode. We have used the geocode function extensively to look at creating a new unit within our stake. All during that process we used the geocodes to create reports that helped us fill in the required form that gets sent to headquarters for creating a new unit. We haven't used the geocodes for several weeks now as the form and maps have all been sent on to the Area Seventy and on to SLC. However we needed to create a list of Melchizidek priesthood brethren that would be located in the new unit but we can't get the report to work.

An example is we used the following criteria for the new report:
Priesthood is Melchizidek
Stake Geocode is *** (where the geocode is part of the new unit)

We followed all the appropriate steps but the report just won't come up. I called LUS and asked them to see what might be the problem. After doing a "send/receive" they used our most current data and they are unable to create a report either with our database. They are turning the issue over to the programmers but it will probably take a week or more before we hear back. Fortunately, while doing all the leg work for creating the geocodes and final report we kept quite a bit of the data (along with several custom reports that we created). We can use the paperwork we created to get the list of MP brethren we are looking for but the custom reports created (any that have a geocode as part of the criteria) will not work.

Any ideas of what may have happened? Really just curious more than anything else as to why one function worked great a couple of weeks ago and now won't work at all. - btw, any of our other custom reports that do not include geocodes work just fine!

Posted: Sat Jul 14, 2012 3:10 pm
by jeromer7
I have no idea why your custom reports aren't working with Geocodes. I have never used custom reports in boundary modeling as I find the tools in the boundary proposals area of MLS give all the relevant info.

Specificially, there's statistics page in there (boundary proposals) that will give you quarterly report type stats on each unit in your model.

Posted: Sat Jul 14, 2012 4:56 pm
by atticusewig
Is it only the criteria of geocode, or also the listing portion also ?

For example, If the criteria is set to only Melk. Preisthood, but the
display settings include displaying the Stake Geo code, will it list all the Priesthood
Brethren, and what their current geocode (which could then be
sorted by column, exported to excel, etc - providing a work-around),
or is the display column blank for the stake geo code (indicating data loss) ?

Posted: Sat Jul 14, 2012 5:39 pm
by ffrsqpilot
Didn't think about doing it by just MP as the only criteria and then having the report list all geocodes and then sorting. We actually were able to get the list we were looking for by using some of the paperwork that we saved and created a list that way. My curiosity is why using geocode as a criteria no longer allows us to make a report. What our intentions were was to use MP as a criteria and all of the nine (9) geocoded areas that will be incorporated into the new unit.... thus the criteria for the report would be: Priesthood is MP; stake geocode is ***, and or stake geocode is *** and so forth using all 9 geocodes that will make up the new unit. The report wouldn't work with 9 geocodes so we tried with just one geocode and that didn't work either. LUS couldn't make it work either. So it must be some function of custom reports and geocodes that is no longer meshing.

I am not saying this is a MLS wide glitch....just a glitch for our stake computer (I am guessing). Still wondering why it worked several weeks ago and not now when nothing has changed as far as I know. All geocodes still show up in the computer (hate to think about having to go through that process again). So some function of geocodes and custom reports is not working since I can create any other custom report as long as none of the criteria is a geocode.

Posted: Mon Jul 16, 2012 1:10 pm
by RossEvans
As a workaround you might try exporting the Membership.csv file from the File -> Export menu. That export file includes the Geo Code fields as well as Priesthood. It should be easy to pop that file into a spreadsheet to filter the report you need.

Posted: Tue Jul 17, 2012 10:36 pm
by mtwerner
You're not alone; I've noticed the same problem. However, this functionality seems to be sporadic. Reports with geocodes have also worked for me previously, but a couple of weeks ago I noticed they weren't working. They did, however, work the other day, but once again not today. There's no rhyme nor reason to it.

Posted: Wed Jul 18, 2012 2:35 pm
by ffrsqpilot
Heard back from the MLS support team today - programmers say there is a definite bug in the system. Any custom report with geocodes in the criteria will not work. They don't know when it will be fixed. Really glad I got the work I needed to form a new unit done before this glitch happened.