Page 1 of 1

LDS Tools not working after factory reset of phone

Posted: Sun Aug 05, 2012 8:53 pm
by ajthomas
I upgraded to the latest version of LDS Tools when it became available a couple of weeks ago. It worked fine then and I was pleased with the improvements. However, a couple of days ago I had to do a factory reset of my phone for some other unrelated reasons. I reinstalled LDS Tools, and now the application won't start. It tries to start, then I get an error message saying that the application has stopped unexpectedly. This continues after repeated uninstallations and reinatallations of LDS Tools and deleting all of the saved data on the SD card. I even did another factory reset and only installed LDS tools and nothing else. It still won't work.

Has anyone else experienced anything similar?

By the way, this is Android 2.1 on an older Motorola Cliq.

Posted: Sun Aug 05, 2012 9:04 pm
by ajthomas
Well, what do you know. I guess the solution to the problem was to just post a thread about it. Even though I had tried starting the program probably a couple of dozen times, restarted the phone numerous times, repeated the factory reset, uninstalled and reinstalled several times, all without success or even any hint of success, it started just fine when I thought to just try it one more time for no particular reason right after starting this thread. I didn't do anything different this time, but it worked anyway.

Well, I suppose if anyone has experienced anything similar, or if anyone knows what the issue might be it might still be good to post it here as a resource for future users.

Similar Problem

Posted: Wed Oct 10, 2012 12:05 am
by scottmnichols
Ever since the Aug update I've been unable to access LDS Tools. Reinstall doesn't seems to do any thing. I have the Cliq as well and I just wonder if the phone is the problem. I don't think so since it was the app that changed.

Found Old LDS Tools Version

Posted: Wed Oct 10, 2012 4:57 pm
by scottmnichols
I found the web page with the older/previous versions of LDS tools and installed the build from june 2012. The app works great, the way it used to before the newer versions were released. It doesn't have the latest updates but it works.
Try going to this site on your device and downloading an older version: look under Other Releases.

Posted: Sun Oct 14, 2012 4:20 pm
by ajthomas
The next update shortly after my previous posts fixed it for my phone and it started working again. At some point about that time, however, I also flashed a custom ROM to my phone, so that I'm no longer running the stock version of Android. It's now a custom version of Gingerbread (Android 2.3). I don't remember for sure, but that might have had something to do with fixing it for my phone.

A couple of days ago it started crashing again. I uninstalled and reinstalled the program and it began working again.