Page 1 of 1

Book of Mormon JAVA ME Download Scripture Lines Hidden

Posted: Sun Sep 02, 2012 2:38 pm
by fehljam
I'm new here. I hope I am posting this in the proper location. If not, I apologize ahead of time.
I have a non-smart phone (no iPhone or Andriod here, sorry). I have downloaded and installed the LDS JAVA applications for the Book of Mormon and Gospel Library that are located at: ... E_download ... E_download

They work great! Unfortunately, I have one problem. At the bottom of the screen for the soft key menu is listed EXIT. All well and good, however that bottom line displays over a line of scripture and sometimes when I page down to the next page/verse the application does not display the line that was covered up by the menu on the bottom, making me miss lines of scripture that I can't see. It does not happen for every page down, just sometimes. I'm not sure the logic the JAVA code does to display the text.
I've tried everything I can think of, every option on the phone to scroll down ONE LINE instead of ONE PAGE (can't find that, that would solve it!) or remove the softkey menu and nothing. Frustrated at missing lines of scripture!
This happens with both the Book of Mormon separate JAVA download and the Gospel Library download. (I can give specific lines if details for an example would help, but each phone may display a different number of lines depending on screen resolution)
I've tried changing the display size in the .jad and .jar (edited and saved using WinRAR) using:
MIDlet-Target-Display-Size: 400 ,240 (yes, the screen is wider then high - Sanyo Innuendo if that helps)
I've tried making the display size (height even smaller), hoping it would not display text down under the soft key menus. But nothing works.

So stumping around on the web for a solution, I came upon this website.
I hope I've explained this well enough for you all to understand.
I'm hoping someone here can help out!
I hope the JAVA version is being supported, we all don't have smart phones. :)

P.S. In the JAVA application, in the listings for Jacob, it lists the chapters as "Chapter X" as with the rest of the books. However, for Jacob chapter 4 it lists "Jacob 4". Just a little inconsistency. I eazily fixed this by editing the .xml in the .jar, but maybe the official download version can be updated?