Page 1 of 1

Unable to download PoGP & more

Posted: Mon Oct 19, 2015 7:30 pm
by cboling
Most of the content on my device is fine, however several documents -- most notably the Pearl of Great Price -- are missing, and every time I tap their faded icons to download & install them, I get an error message:
an error occurred while downloading "Pearl of Great Price"
and the download fails.

I have tried uninstalling the app and deleting all the related files I could find, to no avail.

I searched the forums and found a couple of threads listing that error message, but they didn't seem to apply here.

Any ideas? (besides a factory wipe of the phone)

Some notes:
1. Sorry for not providing more details on exactly what files I found and deleted; it's been a while since my last attempt, and I lost my notes.
2. This problem may have been triggered following one of several restores from defective phones to replacements.
3. Device is ZenFone2, notable for Intel processor and emulated SD card.

Re: Unable to download PoGP & more

Posted: Mon Oct 19, 2015 7:52 pm
by lmcguire

Did you try using the Android App Manager to "Clear Data"? This will delete everything (including settings), and clear the cache for the app. Then, after doing that, power cycle the device (full power off, wait at least 30 seconds, then power up). Then open the app and run through it all again - I recommend starting with just downloading and subscribing to the scriptures collection before wasting time on anything else.

(I have had problems with my library getting corrupted, and the above fixed it.)

That's my only guess, and if that doesn't work, I'd say there's something up with the device (or its Android install). If that's the case, you might see if there are any updates for the device (usually in Settings > About..., but your Android version could have different options).



Re: Unable to download PoGP & more

Posted: Mon Oct 19, 2015 8:09 pm
by cboling
Thanks for the memory jog, Liz -- I had indeed tried that too (except perhaps for the power cycle). I went ahead and did everything as you described, to no avail. I also skipped entering my account info, in case something there could somehow interfere. Watched it launch w/ "Creating database" message, caught it in the process of automatically downloading the scriptures (It was fast enough that OT/NT/D&C were already done by the time I saw it, but BOM was still finishing) and the PoGP remained un-downloaded. :-(

Re: Unable to download PoGP & more

Posted: Sun Nov 15, 2015 9:46 am
by cboling
Anyone else have an idea?