Page 3 of 6

Posted: Fri Apr 17, 2009 8:53 pm
by jdlessley
My point of comparison is general conference streams versus the test webcast stream. I run my monitor at 1440x900. General conference is not perfect but significantly better than the test webcast stream. I dropped my monitor's resolution to 800x600 and still the webcast stream resolution was low. The items I noticed the greatest problems with were the people walking about. They look like moving pixels rather than people.

Posted: Fri Apr 17, 2009 9:07 pm
by rmrichesjr
tsheffield wrote:For those who would like to see the Meetinghouse Webcast equipment in action you can now go to It is a great tool for testing receiving location bandwidth capabilities.
That URL returns what appears to be a playlist. The second URL in the playlist has a numeric IP address in the 10.*.*.* block. If I understand correctly, that IP address won't likely be accessible outside the Church internal network.

Something else is odd. I can usually get at least close to viewing most multimedia stuff on my home Linux machines. However, when I attempt to download from the first URL in the playlist, the content is exactly the same as the playlist itself.

Posted: Fri Apr 17, 2009 9:23 pm
by russellhltn
They all look fine to me. Right now is a bad test because it's dark. The water looks a bit funky, but I think it's a compression artifact. The cars flow normally.

Posted: Fri Apr 17, 2009 10:42 pm
by lionelwalters
tsheffield wrote:For those who would like to see the Meetinghouse Webcast equipment in action you can now go to It is a great tool for testing receiving location bandwidth capabilities.

Thanks for posting this. After reading so much about the Webcast kit, it's great to actually see it in action. Is it right that it's broadcasting at only 320x240? Quality is not bad though. I look forward to seeing the stream in daylight.

Posted: Fri Apr 17, 2009 11:20 pm
by MorettiDP
I hope the day it will be available in Brazil.

Posted: Sun Apr 19, 2009 1:46 pm
by rmrichesjr
Now, it's working for me, too. On my home Linux machine, I saved the content of the posted URL, to disk, then ran mplayer on the first URL from inside the saved file. That's the same thing I had tried earlier when it didn't work. Perhaps, my earlier attempts were during server maintenance. I'm glad the solution is inter-operable.

The image does appear to be 320x240. Here's a little of what mplayer says about the feed:

VIDEO: [WMV3] 320x240 24bpp 1000.000 fps 241.0 kbps (29.4 kbyte/s)
AUDIO: 32000 Hz, 2 ch, s16le, 32.0 kbit/3.12% (ratio: 4000->128000)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
VDec: vo config request - 320 x 240 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)

The 320x240 resolution isn't too bad. Even blown up to full-screen mode on a 1600x1200 monitor, it's not bad. That resolution would certainly be sufficient for a projector in a chapel.

Looking at the motion of the few people walking around and the occasional vehicles on the street, it looks pretty smooth to me. Of course, there's little enough activity that the bitrate is probably sufficient to transmit almost all the deltas with little loss. A more active scene would likely show more compression artifacts. However, a few minutes, ago, the fountain activated, and it looked okay as far as I could tell.

I remember the spider that got in front of the Nauvoo Temple camera. I hope no "bugs" get in the way of this demo. :-)

I'll definitely make sure my stake's STS knows about this.

(My mother lives in Salt Lake. One of the next times she is in the area, I expect a phone call so she can talk to us while she waves at the camera.)

Posted: Sun Apr 19, 2009 2:03 pm
by russellhltn
Some interesting experiences this morning. It took several tries to come up. Many times it simply brought up WMP and then entered "stop" mode.

I did get it running and it looked fine, then for some reason (maybe my fooling around) it went to one frame every 5 seconds.

I killed it and restarted (took two tries) and it came back.

Posted: Sun Apr 19, 2009 2:14 pm
by russellhltn
Same thing. Runs fine, then goes to one frame every 3-5 seconds. This is within 10 minutes of running time. It might be an ISP issue. I'm on minutes cable right now.

Posted: Sun Apr 19, 2009 2:41 pm
by rmrichesjr
I wonder whether some of the difficulties, these recent ones and my earlier ones, might be a limit on the number of outbound streams from this demo URL.

Posted: Sun Apr 19, 2009 3:04 pm
by rmrichesjr
Not to monopolize the thread too much but ...

It turns out my stake's STS already has the new equipment, both sender and receiver, and that's what was used for our stake conference this morning. Out stake didn't have a new camera, and the old camera has age-related issues. There may have also been some audio level issues (sounded like analog clipping) ahead of the digitizer. Other than that, it worked quite well.