Password reset, but still not working.

Discussions around the Android version of the Member Tools application
Post Reply
ryanprobst
New Member
Posts: 1
Joined: Wed Jul 15, 2020 11:06 am

Password reset, but still not working.

#1

Post by ryanprobst »

My LDS tools account has not been working for some time now. I reset my lds.org password today and I still cannot access LDS tools app. It never accepts my passwords. It just continually tells me to try again and then locks me out. I do not know what else to do. I have uninstalled the app and reinstalled it, and tried everything.
russellhltn
Community Administrator
Posts: 31522
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Password reset, but still not working.

#2

Post by russellhltn »

Does your account work on the main site to get you into the directory?
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
Post Reply

Return to “Android Member Tools App”