Connecting to Liahona WiFi

Discussions around miscellaneous technologies and projects for the general membership.
tannerlex
New Member
Posts: 1
Joined: Thu May 27, 2021 9:33 pm

Re: Connecting to Liahona WiFi

#11

Post by tannerlex »

I also have this issue currently. I'm using a Ubuntu 18 laptop. I never get the splash "continue to internet" page. I have not had this kind of issue at hotels which share a similar method.
russellhltn
Community Administrator
Posts: 31312
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Connecting to Liahona WiFi

#12

Post by russellhltn »

I'd make sure you're using the DNS provided by the network and not some other - perhaps as some kind of performance improvement or filtering. It's possible the hotel systems are intercepting DNS calls instead of blocking them.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
if009
New Member
Posts: 1
Joined: Sun Jun 27, 2021 2:00 am

Re: Connecting to Liahona WiFi

#13

Post by if009 »

Were you able to get the captive portal detection to work? If not try resetting the NIC
riffr49
New Member
Posts: 1
Joined: Sun Jul 11, 2021 9:33 am

Re: Connecting to Liahona WiFi

#14

Post by riffr49 »

I had this same issue today and was able to finally connect by allowing pop ups. Because they were disabled they page that opens up where you connect to the internet was never opening. Once I went into my settings in Chrome and did that I was able to connect. There is also a way you can block all pop up except from approved sites. You should see it in the settings when you go to enable pop ups. Hope this helps
jcluff47
New Member
Posts: 1
Joined: Sun Oct 24, 2021 8:08 am

Re: Connecting to Liahona WiFi

#15

Post by jcluff47 »

For those on Mac, this worked for me:
  • Click the Apple icon in top left
  • Select System Preferences
  • Select Network
  • Select Wi-Fi
  • Click "Advanced"
  • Select the "DNS" tab
  • Make sure there is no entry there that is not greyed out; the font will look white if there is an existing entry. The church configures their own DNS addresses when you connect to their network. If it is working properly you should probably see two greyed out IP addresses. In my case they were 8.34.34.101 and 8.35.35.101. What I found was that I had a permanent DNS entry that I had previously setup.
  • To delete the address simply click on the entry and click the "-" (minus) button.
  • Click OK
Once I did all of that it popped up the splash screen. Hopefully this helps someone.
Last edited by jcluff47 on Sun Oct 24, 2021 8:17 am, edited 1 time in total.
milnerm1
New Member
Posts: 1
Joined: Tue Dec 29, 2020 9:48 am

Re: Connecting to Liahona WiFi

#16

Post by milnerm1 »

I have an older Mac (2011), and have the symptom where the authentication screen never appears after the WiFi connects. The following works for me:

- Open Safari.
- Open an incognito window.
- Browse to captive.apple.com.

This loads the elusive, “Continue to the Internet” screen.

Hopefully this can be useful to someone.
Post Reply

Return to “Other Member Technologies”