Usage of Church account with MacBook

Church Account is the primary user account (user name and password) for accessing online Church resources. Church Account was formerly known as LDS Account. This forum is a space to discuss all things related to Church Accounts (registration, account recovery, user experience, vulnerabilities, etc.).
Post Reply
mhaberma
New Member
Posts: 2
Joined: Thu Mar 11, 2021 1:40 pm

Usage of Church account with MacBook

#1

Post by mhaberma »

I am using my church account with Apple products. When I sign into my church account with my iPad and iPhone I can properly use my account and all the church resources. I can donate online and connect to the resources for leaders and finances.

But when I sign on my account from my MacBook, which I would like to be the primary access point, then its not loading any pages. I cannot access our branch membership or financial information anymore, I make any donations, etc. Its frustrating.

How can I change that?
russellhltn
Community Administrator
Posts: 31975
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Usage of Church account with MacBook

#2

Post by russellhltn »

My go-to advice on church webpages is to try incognito mode. Church webpages have problems with cookie buildup over time.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
mhaberma
New Member
Posts: 2
Joined: Thu Mar 11, 2021 1:40 pm

Re: Usage of Church account with MacBook

#3

Post by mhaberma »

That actually worked. I deleted all the cookies before and it still didn't work, but now in the incognito mode it worked. Thank you! Thats weird but a positive result. Still wondering if there is anything else I could do
russellhltn
Community Administrator
Posts: 31975
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Usage of Church account with MacBook

#4

Post by russellhltn »

mhaberma wrote:I deleted all the cookies before and it still didn't work, but now in the incognito mode it worked.
Not sure what to suggest to get it to work in normal mode. Clearly, there's something not getting deleted.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
Post Reply

Return to “Church Account”