Beta Directory Issues

Discussions about the Directory Tool on lds.org. Questions about the Directory on the classic site should be posted in the LUWS forum.
zaneclark
Senior Member
Posts: 1179
Joined: Thu Jan 24, 2008 4:34 pm
Location: Las Vegas, NV
Contact:

#151

Post by zaneclark »

RussellHltn wrote:Just out of curiosity, are those that are NOT working getting different IPs then the following when doing a "ping" from a command prompt?

beta.lds.org -> 216.49.176.48
secure.lds.org -> 216.49.176.34


I just checked and the IP's are the same.
danpass
Senior Member
Posts: 500
Joined: Wed Jan 24, 2007 5:38 pm
Location: Oregon City, OR
Contact:

#152

Post by danpass »

danpass wrote: I do use firebug and will look to see if the console provides any useful information. Thanks!
I have already sent this information to jdcr256 in a PM. For anyone else who is interested, after submitting my credentials to gain access to the beta directory, I get the following javascript error in the firebug console:

Code: Select all

stakes is null
    if (stakes.length > 1){                     unitSelector.js (line 8)
Would one of you who is not having problems accessing the beta directory and has firebug installed, please check to see whether or not you see this error?
jonesrk
Church Employee
Church Employee
Posts: 2013
Joined: Tue Jun 30, 2009 8:12 am
Location: South Jordan, UT, USA

#153

Post by jonesrk »

danpass wrote:I have already sent this information to jdcr256 in a PM. For anyone else who is interested, after submitting my credentials to gain access to the beta directory, I get the following javascript error in the firebug console:

Code: Select all

stakes is null
    if (stakes.length > 1){                     unitSelector.js (line 8)
Would one of you who is not having problems accessing the beta directory and has firebug installed, please check to see whether or not you see this error?
For me stakes has one entry and it is my stake.

I wonder if the issue is related to your stake/ward or if it is related to your information tying you to your stake.

Do you know if others in your ward/stake can log in or are then having the same problem?
danpass
Senior Member
Posts: 500
Joined: Wed Jan 24, 2007 5:38 pm
Location: Oregon City, OR
Contact:

#154

Post by danpass »

ryan jones wrote:For me stakes has one entry and it is my stake.

I wonder if the issue is related to your stake/ward or if it is related to your information tying you to your stake.

Do you know if others in your ward/stake can log in or are then having the same problem?
danpass wrote:I have already sent this information to jdcr256 in a PM. For anyone else who is interested, after submitting my credentials to gain access to the beta directory, I get the following javascript error in the firebug console:

Code: Select all

stakes is null
    if (stakes.length > 1){                     unitSelector.js (line 8)
Would one of you who is not having problems accessing the beta directory and has firebug installed, please check to see whether or not you see this error?
The only other person I have asked to try is the ward clerk in my ward. He has the same problem that I have.
russellhltn
Community Administrator
Posts: 31499
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

#155

Post by russellhltn »

danpass wrote:

Code: Select all

stakes is null
    if (stakes.length > 1){                     unitSelector.js (line 8)
If I read this right, it's designed to send to you a selection screen if you belong to more then one unit.

So, is this only affecting those who have "out of unit" records? I'm working fine, and my records are "normal" in that they only belong to one ward.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
jonesrk
Church Employee
Church Employee
Posts: 2013
Joined: Tue Jun 30, 2009 8:12 am
Location: South Jordan, UT, USA

#156

Post by jonesrk »

I think I might have it. There was an issue recently with Family History centers showing up in the list of children units that was causing a problem.

Both the stakes for zaneclark and danpass have an Area CS Missionary Group as a child of their stake.
zaneclark
Senior Member
Posts: 1179
Joined: Thu Jan 24, 2008 4:34 pm
Location: Las Vegas, NV
Contact:

#157

Post by zaneclark »

ryan jones wrote:I think I might have it. There was an issue recently with Family History centers showing up in the list of children units that was causing a problem.

Both the stakes for zaneclark and danpass have an Area CS Missionary Group as a child of their stake.
This sounds encouraging! Does this mean I might be able to see the directory soon?
n.oliver
New Member
Posts: 30
Joined: Sun May 09, 2010 9:21 pm
Location: USA, AZ

#158

Post by n.oliver »

zaneclark wrote:...to those of us still watching the spinning wheel?
I would think an error msg box would be helpful, in the event of unexpected AJAX data result (JSON?), AJAX error, etc. And as this is in beta, perhaps a checkbox for displaying detailed error messages (for script errors) to the user would be good.

Not all beta users will know how to use Firebug, and the more easily they can see the error messages the more easily they can relay them back here.

Kinda hard to get people to use a site that just sits there "loading" with no messages...eats a lot of time
zaneclark
Senior Member
Posts: 1179
Joined: Thu Jan 24, 2008 4:34 pm
Location: Las Vegas, NV
Contact:

#159

Post by zaneclark »

zaneclark wrote:This sounds encouraging! Does this mean I might be able to see the directory soon?
Haven't heard anything on this so I sent another note to feedback..... They are probably getting tired of hearing from me, but I am really anxious to get this thing functional again.....
jdcr256
Church Employee
Church Employee
Posts: 557
Joined: Wed Feb 17, 2010 1:53 pm
Location: Riverton, Utah

#160

Post by jdcr256 »

We have an update that should roll out in the next three days. Those of you that are having problems, let me know if you continue to have them after the update (I'll post again here once the update is out).

I have not been able to duplicate this issue yet, so I'm keeping my fingers crossed. This update will move directory to the new authentication method that the main beta.lds.org is using. I suspect the problem we are having now is related to the old authentication system, so I'm hoping the change will fix it.

Thanks for all the info and good sleuthing that has been going on here.
Post Reply

Return to “Directory”