MLS not recognizing outgoing data

Discussions around using and interfacing with the Church MLS program.
Post Reply
User avatar
New Member
Posts: 35
Joined: Sun Sep 21, 2008 10:22 pm
Location: Ohio, USA

MLS not recognizing outgoing data


Post by cjbeckert »

We have been experiencing a problem with MLS not recognizing outgoing data. Our stake technology specialist has tried to work the issue but has made little progress.

After completing an update (such as writing a check, entering donations, recording an ordinance, requesting MR move in, updating address, etc.), the transaction is queued. This is verified by looking in the File > Membership Record Transaction Report, or Finance Record Transaction Report. During the Send/Receive Changes, it appears data is uploading but no transaction report prints after the transmit is done. I check the File > MRTR or FRTR and the transactions are still showing queued and waiting to be sent. I exit MLS and receive the warning screen that checks have not been transmitted. However, when I call CHQ, they confirm the donation batch or checks were received. So, transactions are going out but MLS does not recognize data went out which should trigger the queue to be cleared and report(s) to print. The queue does not clear and print report(s) until we receive inbound data such as a MR moving in.

Additionally, we have not received a CUFS since the problem began in late-March despite repeated attempts to request them via MLS. All this appears to have started shortly after updating the web browser to IE8 after the site gave us an error message saying our browser version was too old. It may or may not be related. Any ideas or suggestions before we resort to completely ripping out MLS and starting over?
User avatar
Community Administrator
Posts: 15141
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah


Post by aebrown »

cjbeckert wrote:Any ideas or suggestions before we resort to completely ripping out MLS and starting over?
It sounds like the problem is either in the database or the installation of MLS. If it's in the installation, then I would recommend doing a full installation of MLS. That can be done quite simply -- just have your stake technology download the full MLS install from and install it over your existing installation.

If that doesn't work, then I'd uninstall MLS and then install it again. Before doing this, I'd preserve the Units folder and the file from the MLS folder. However, I wouldn't be too scared of this option; you can uninstall and reinstall in under 15 minutes, so it's pretty easy to do.

If neither of those steps works, then I'd guess your problem is in your database. Only Local Unit Support can help you with that; they can set a flag so that the database is transmitted to CHQ on the next Send/Receive. Then the MLS developers can examine your database to determine what is wrong and how the database can be fixed.

It sounds like you are working with your stake technology specialist, which is good -- all these steps should be done by him or at least coordinated with him.
Questions that can benefit the larger community should be asked in a public forum, not a private message.
Community Administrator
Posts: 32234
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.


Post by russellhltn »

In addition to Allen's advice, make sure all MLS users are logged into Windows with the user ID of "Clerk" and that it is an Administrator in Windows. Someone may have been trying to tighten security without realizing that the setup I just described is policy.

Also, I've seen problems caused because units don't reboot their computers - they just leave them on. (Or perhaps cause them to hibernate.) MLS may need the reboot to complete some updates.
Have you searched the Help Center? Try doing a Google search and adding "" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
User avatar
Senior Member
Posts: 854
Joined: Thu Feb 28, 2008 5:45 pm
Location: Hillsboro, OR


Post by mfmohlma »

I have been having this same problem for a few months now. Every time I call support, they tell me it's a known issue and that the checks are received even though MLS indicates they are not sent. In most cases, the Finance Transmission Report prints days later. I have also not received a CUFS since March, and there seems to be evidence that the statements are "stuck" in the "Show Send/Receive Status" page. I have had to have support email the CUFS to my bishop.

Every time I call, they also tell me that this is a semi-widespread issue and that the programmers are working on this. Hopefully it will be fixed soon. I'm surprised they didn't mention the same thing to you. If not, the entire bishopric will soon be desensitized to the warning messages given on exiting MLS about transmitting financial transactions. :(
User avatar
Senior Member
Posts: 854
Joined: Thu Feb 28, 2008 5:45 pm
Location: Hillsboro, OR


Post by mfmohlma »

cjbeckert wrote:The queue does not clear and print report(s) until we receive inbound data such as a MR moving in.
Ah, I was trying to figure out exactly why the reports printed semi-randomly. I guess all have to do now is keep changing my phone number on to keep inbound changes coming. ;)
cjbeckert wrote:...before we resort to completely ripping out MLS and starting over?
I've tried this already and it doesn't help... :(
Senior Member
Posts: 1266
Joined: Mon Jul 07, 2008 4:05 pm
Location: USA


Post by crislapi »

I'm w/ oregonmatt on this one. Some of our units have issues, but only 2-3, and it varies. I also called support and was told this is a known issue. Specifically, the issue is not in going from your computer to CHQ but the other way around. Once the batch is received, a confirmation is transmitted back. This is what your MLS is not receiving and you are prompted to transmit until you do receive it. I was told that after 2-3 times, it should come through and stop prompting. I, however, had had better luck logging out and closing down MLS and restarting. Not sure why that helps, though...

I was also told that the next version of MLS would contain a fix for that. And, luckily enough, I received a message today that the next version will be coming in the next week or two. I was also given the option of downloading the beta if I wanted to.

I will also admit to trying to do a completely fresh reinstall of MLS. It didn't help, so I'll save you that approach.
User avatar
Senior Member
Posts: 1556
Joined: Tue May 27, 2008 5:14 am
Location: Watford, England


Post by Biggles »

We have just been informed, that hopefully this coming weekend, there will be an upgrade to MLS, to cure these error messages.

Quote from the message we received: -

"These messages can be ignored, SLC have made a change to something in the finances module and it has created blank files to be sent to MLS, and MLS does not like them."

We shall look forward to that with great anticipation.:D
Post Reply

Return to “MLS Support, Help, and Feedback”