Page 1 of 1

Disappearing Chapters

Posted: Thu Jun 24, 2010 1:42 pm
by lajackson
Has anyone had trouble with chapters in the scriptures disappearing? I don't know if they were not there when I downloaded the latest update, or if my iTouch corrupted them. After I discovered two missing, I did a thorough review and found that more than a dozen chapters were gone.

Gospel Library has not crashed for me. I consider myself fortunate in that regard, but if they were all there at the original download, my regular use of the app is corrupting the database.

When I got back to WiFi land, I was able to remove each of the scripture books and download them again. This solved the problem, at least for now. I wonder if/when it will reappear, and what may have caused it.

I still have another set of scriptures on my iTouch, and I was able to recover when I discovered the problem, although I discovered two missing chapters on the same occasion, and if I had found a third I would have switched to paper.

Removing and downloading the PofGP also restored the Articles of Faith, which were blank when I did my review, but which were present when I first downloaded Gospel Library.

As a bonus, I had not tried to remove anything since downloading the updated Gospel Library app because it could not be done with the original app. After last night, when all of the remove and download went well, I am convinced that bug has been squashed.

Posted: Tue Jul 27, 2010 9:06 pm
by brock.butler
i actually have so u removed all the data off and i was able to fix the problem but i lost all my notes links and highlight text so it was kinda anoying after all that work it was like i lost my scriptures but it fixed the problems

Posted: Tue Aug 03, 2010 2:34 pm
by ComradeH-p40
This has been happening to me as well. Just last night I found that I was missing the Honesty chapter of Gospel Doctrine. Before that it was Moroni 7. It seems focused on some heavy hitting chapters for me. I don't know when the disappeared. I may go through and reinstall everything to try and get a sense for what might be causing it.

Posted: Tue Aug 03, 2010 3:38 pm
by lajackson
ComradeH wrote:This has been happening to me as well. . . . I may go through and reinstall everything to try and get a sense for what might be causing it.

I have not had any problem at all since I upgraded to version 1.20.1210.10061102. Even True to the Faith works just fine.

Posted: Mon Dec 27, 2010 7:29 pm
by EdHammond
(iPad 16GB WiFi) I had whole chapters of scriptures randoming disappearing as well, and it seemed to be getting worse and worse over time. The latest update (last week) seems to have helped performance A LOT!!!! I had to delete all the scriptures, then re-add them to get the missing chapters back. My guess is that there were indexes that were lost or the internal integrity was compromised. The delete/add action re-integrated the indexes to the libraray and so everything re-appeared as it should have. Working fine so far.