Page 1 of 3

BlackBerry and the Gospel Library

Posted: Thu Oct 07, 2010 3:31 pm
by mkpolansky
I have a BlackBerry Torch and would like to add Gospel Library to it. The application would appear to have downloaded just fine, but cannot seem to load any content after selecting "Manage Library".

Any thoughts?


Posted: Fri Oct 08, 2010 11:58 am
by lajackson
MKPolansky wrote:I have a BlackBerry Torch and would like to add Gospel Library to it. The application would appear to have downloaded just fine, but cannot seem to load any content after selecting "Manage Library".

Any thoughts?

There is a problem with this issue and the iOS right now for the iPhone and iPod Touch folks that the developers are trying quickly to sort out. I am not familiar with the BlackBerry, so I do not know if the problems may be related.

Posted: Sat Oct 09, 2010 7:03 am
by mkpolansky
I'm not sure if it relevant or not, but I have an iPod Touch with the Gospel Library app on it and it works just fine. Obviously it is not my call, but if the BlackBerry app doesn't work, shouldn't it be taken down until it does? If it is an OS 6 issue with BlackBerry, maybe a disclaimer should be put up. Just a thought...

Blackberry Gopsel Library not working

Posted: Sat Oct 16, 2010 3:02 am
by lds_derek-p40
I have been struggling with this issue for months now and have had little response from the support (via the troubleshooting email provided). See email trail below

I have a Blackerry Bold 9700
Software version: 5.0


Thanks for the response but the content will still not download.

Is it possible to post a link to the content that I can download via
my computer and then transfer to the gospel library folder on my BB?


On 9/8/10, (DELETED - Tech support)> wrote:
> Derek,
> There are not separate links to download the content separately. We hope to
> have that soon.
> Apologies for the delayed response,
> On Sep 3, 2010, at 9:50 PM, Derek Bogaert wrote:
> can I get a response please!
> On 9 August 2010 10:39, Derek

> wrote:
> Hi there
> Appreciate a response on the below. I suspect the issue regarding 9700
> compatibility.
> Rgds,
> Derek
> On 3 August 2010 16:29, Derek

> wrote:
> Hi,
> Further the below, I tried to reinstall thinking that might fix the
> issue but noticed the link to download had been taken down. I
> downloaded again today and noticed that the version is now 0.9 from
> 1.0 but still nothing happens.
> The instructions on the web site say to click either scriptures or all
> (additioan material) but I don't even get an option and it just starts
> downloading.
> If you were to provide seperate links for the content I could download
> them via my computer and then transfer to the 'gospellibrary' that has
> been created on my memory card.
> Thanks,
> Derek
> On 7/31/10, Derek

> <wrote:
>> Hi
>> I downloaded the Blackberry mobil gospel library app today. It
>> downloaded and ran no problem but after going to 'manage library' it
>> says 'downloading content' but after 30mins of nothing happening I
>> assume it is not working. I tried both with my wireless network
>> connected and then on regular 3g data with the same result.
>> I am have a BB bold 9700.
>> Live in Melbourne Australia.
>> Thanks for your efforts. I have been anxiously waiting for this app so
>> looking forward to using it!
>> Rgds,
>> Derek

Posted: Mon Oct 18, 2010 7:21 am
by mkpolansky
Interesting. On my iPod touch over the weekend there was an update to the program that opened up a lot more content to would be nice to be able to have even the basic for the BlackBerry. I sent an email to the listed address and haven't heard anything back.

Posted: Mon Oct 18, 2010 12:24 pm
by baregenaina
I have a BB curve 8520 and I tried to dowload content through Manage library but i think I have the same problem, it's says loading but it never dowload anything!!
any help???

Same Problem with BlackBerry Tour

Posted: Mon Dec 06, 2010 11:50 am
by gasparin
I have the same problem, and like those above me, have received absolutely no response using the troubleshooting email. The application downloads fine, but downloading/installing the actual scriptural content has never worked. I must have tried over twenty times (manually deleting the files many times), and the most content I ever got was the Old Testament, New Testament, and the Book of Mormon (using the "install all" option).

Same with BB Curve 8310

Posted: Tue Dec 14, 2010 11:50 am
by winslowohio
I have the same issue with my Blackberry Curve 8310. I am glad it isn't just me. I have sent email and received no response. I wish getting an iPhone was an option but I have to have the BB for work. It is frustrating that they put a product out and then don't respond to any of the requests for support. Are we Blackberry users the unwanted step-children????

And as a side note, I also have problems with the Mormon Channel application. I can get the schedules and menus but if I try to actually listen to something I get "Error downloading media over the network. Retrying...". Of course it is never successful. More evidence that Blackberry's are not well like by Church Technology.

Posted: Wed Jan 26, 2011 8:18 am
by gogogervic
Tengo el mismo problema para blackberry Torch, solo ingresa a la primera vista y luego no hace nada más.

Cambie de una Bberry 8520 en la cual funcionaba bien, pero en esta (9800) OS6 no funciona nada.

I have the same problem for blackberry Torch, it only enters to the first view and soon it does not do nothing else. It changes of a Bberry 8520 in which it worked well, but in this (9800) OS6 does not work anything.

Posted: Sun Jan 30, 2011 4:59 pm
by anbrow
I have used the Gospel Library on a Blackberry Bold 9000 using OS 5, a Blackberry Bold 9700 using the new OS 6, and a Blackberry Torch 9800. On the Bold 9000, it works without any problems at all whatsoever. However, once you get onto OS6 devices, it seems to be less reliable. With earlier versions of the OS6 it would install, download, and allow you to navigate the books, but as soon as you chose to read something, it would come up with a blank screen. However I noticed after updating the OS to a newer version, it worked ok. The first version I found that it worked was (Bold 9700 only) On the Torch 9800, I used os, installed the reader via the COD file, not OTA. I also copied the GospelLibrary folder from another BB with it already installed, to the appropriate place on the SD card, opened up the program, pointed it to use the SD card, and then to manage library. It found all the files and was able to open them. The touch functionality seems to work great for scrolling, and even for zooming and selecting hyperlinked words.

NOTE: I just looked after all this, and saw that the version I was using on all of these was version 1.0.0.