Printing Directory with Photos "The PDF is being generated. This may take a minute."

Discussions about the Directory Tool on lds.org. Questions about the Directory on the classic site should be posted in the LUWS forum.
kylehart
Member
Posts: 50
Joined: Mon May 18, 2009 7:44 pm
Location: Alexandria, VA

Printing Directory with Photos "The PDF is being generated. This may take a minute."

#1

Post by kylehart »

Trying to print this for the Bishopric. Takes forever then times out; never once do I get a PDF file. Is this a known issue? Thanks
User avatar
aebrown
Community Administrator
Posts: 15141
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

#2

Post by aebrown »

kylehart wrote:Trying to print this for the Bishopric. Takes forever then times out; never once do I get a PDF file. Is this a known issue? Thanks
It worked for me. My ward's directory with photos took a minute and 25 seconds to generate.
Questions that can benefit the larger community should be asked in a public forum, not a private message.
jdlessley
Community Moderators
Posts: 8976
Joined: Mon Mar 17, 2008 12:30 am
Location: USA, TX

#3

Post by jdlessley »

No problems here either. My ward directory took 40 seconds to generate. But then the ward is small and we only have fourteen photos.
JD Lessley
Have you tried finding your answer on the ChurchofJesusChrist.org Help Center?
kylehart
Member
Posts: 50
Joined: Mon May 18, 2009 7:44 pm
Location: Alexandria, VA

#4

Post by kylehart »

I wonder if that is the problem. We have probably close to 200 photos. Either way, I am unable to generate it. On Firefox it eventually throws a 502 proxy error; on IE (where I have the option to Save the PDF and not just Open it) it just spins forever.
jdcr256
Church Employee
Church Employee
Posts: 557
Joined: Wed Feb 17, 2010 1:53 pm
Location: Riverton, Utah

#5

Post by jdcr256 »

It takes me 61.5 seconds to generate a photo directory with 174 photos in our test environment (tiny fraction of the horsepower production has, but no load). It succeeds for me every time. Could you answer the following two questions:

1 - How long (as exact as possible) before you get the error message in firefox? Is it the same every time, or does it vary? (if you're comfortable with firefox add-ons, you can use the lori plugin to get exact times, just search the add-on manager for 'lori')
2 - Do you have any photos in your directory that are broken (don't load in the web app)? To check this:
a) Click the photos link on the left side.
b) Once all the photos have had time to load, scan through the page, looking for a missing photo.
c) If there is no photo uploaded, you'll see the silhouette placeholder
d) If a photo is broken, you'll just see the families name as a hyperlink where the photo should be, no photo and no placeholder image.
atom88
New Member
Posts: 17
Joined: Sun Jan 02, 2011 7:30 pm

Photo directory - NO PDF can be generated?

#6

Post by atom88 »

I have the same problem in my ward's directory. I see photos for the 90% of the ward who has household photos uploaded. However, when I try to generate a PDF it just spins forever and never returns with a PDF. I waited several minutes (5-10 minutes) and nothing.

Help!
cmr3rd
New Member
Posts: 16
Joined: Sat Jan 15, 2011 9:36 pm

#7

Post by cmr3rd »

Really Frustrating. When trying to print a directory with photos, (and sometimes without photos), I get a proxy error after about two minutes of waiting:


The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /directory/services/ludrs/print/124/ward/.Reason: Error reading from remote server

Seems to be an old problem still occuring. Any ideas why this contnues to happen? Thank you
HarperAB
New Member
Posts: 7
Joined: Mon Apr 25, 2011 4:29 pm
Location: Riverton, UT

#8

Post by HarperAB »

Thanks for bringing this to our attention. I'll have our guys investigate.
atom88
New Member
Posts: 17
Joined: Sun Jan 02, 2011 7:30 pm

#9

Post by atom88 »

I get this error when I tried this morning: 502 Proxy ErrorProxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /directory/services/ludrs/print/95214/photos/.
Reason: Error reading from remote server

Apache/2.2.3 (Linux/SUSE) Server at lds.org Port 80
atom88
New Member
Posts: 17
Joined: Sun Jan 02, 2011 7:30 pm

#10

Post by atom88 »

p.s. I've tried with the firefox and MSIE browsers. I've also tried the "open PDF" and "Save PDF" buttons. Neither of them seem to work.
Post Reply

Return to “Directory”