HP Touchpad apps

Discussions around the WebOS (Palm Pre, Palm Pixi, HP Touchpad) versions of the Gospel Library application.
New Member
Posts: 13
Joined: Thu Aug 25, 2011 5:42 am


Post by ljerryd »

Not a show stopper for me, but I would not object to using my space on the TouchPad for all the content. No rush on my part. Maybe offer both to those who don't care to have it all?
New Member
Posts: 2
Joined: Tue Dec 20, 2011 8:05 pm

Thank you!


Post by aaronseable »

I just wanted to thank all of you who are working on updating the Gospel Library content for the Touchpad. You're doing a great work, and that are a lot of us out there who are grateful and who could not do it on our own!!!
New Member
Posts: 1
Joined: Thu Dec 29, 2011 4:34 pm

Help please


Post by Smi5mom »

I thought I had followed the steps to download the update. It shows up on my G: drive when I have my HP connected to the computer, but when I unplug it, I can't find it on my HP.
Let me see if I doing this right:
I download the zip folder to my computer
Go in and extract the .ldssa folder to the G:drive

Thanks for taking the time to figure this out for all of us.

New Member
Posts: 22
Joined: Tue Sep 06, 2011 10:08 pm


Post by afanofosc »

One thing that some people have encountered when attempting to use my revised webos Gospel Library app is that no additional content is showing in the menus. I think this is caused by the official signed version of the application being still on your device when you use Preware or WebOS Quick Install 4.3.1 to install the IPK from my BricxCC sourceforge page. You may have better luck if you first delete the official version before trying to install my build.

Here is a copy of the instructions (partially specific to Windows) I sent via email to Nancy.

1. Use Windows Explorer to create a folder on your C: drive called "touchpad" (i.e., c:\touchpad).

2. Use your browser to download the following files to the c:\touchpad\ folder
http://bricxcc.sourceforge.net/org.lds. ... .4_all.ipk

3. Download the WebOS Quick Install 4.3.1 from this link and save it to c:\touchpad\:
http://dl.dropbox.com/u/2774158/WebOSQu ... -4.3.1.jar

4. Turn on developer mode on your HP if it is not already turned on. Enter webos20090606 into Just Type and choose to launch the Developer Mode app that appears. If the slider in the top right corner says ON then you can simply close the app and continue. If it says OFF then slide it to the right to turn it ON then tab Submit without entering any password.

5. Connect your device to your computer via the USB cable and select USB Drive mode to have your device show up as a removable disk on your computer.

6. Extract webos_content.zip to the root of this new drive, for example, d:\ if that is the drive letter assigned to your device. In Windows Explorer you should see a folder called d:\.ldssa and if you expand that folder you should see "content" and within that folder "eng" and then a few folders below that which contain the gospel library content.

7. Switch back to the c:\touchpad\ folder in your Explorer window.

8. Right click on the D: drive (or whatever drive letter is assigned to your HP) and choose Eject to safely exit USB Drive mode.

9. While still connected via USB but no longer in USB Drive mode, double click the WebOSQuickInstall jar file in the c:\touchpad\ folder. It should launch. It may ask to install novacom drivers. If it does not launch you may need to install the Java runtime version 1.6 on your computer. Hopefully it launches, installs the drivers it needs and eventually displays a simple GUI that shows that your HP TouchPad is connected and ready in the top right corner of the window.

10. If you get this GUI then click the + sign button and browse for the IPK file in c:\touchpad\ Select the file and add it to the Files to install list shown above. Then click Install. That should correctly install my version of the Gospel Library app on your device.

11. Close the installer.

12. Launch the Gospel Library application and enjoy the additional content.

Let me know via email (afanofosc at comcast dot net) if you still can't get this to work.

I've uploaded zips and my IPK to dropbox at the following URLs:

http://dl.dropbox.com/u/53437658/org.ld ... .4_all.ipk
http://dl.dropbox.com/u/53437658/webos_ ... n_full.zip
http://dl.dropbox.com/u/53437658/webos_ ... artial.zip

I broke up the content zip into two parts: original and new. webos_content_orig contains all the XML content from the official version of the webos Gospel Library application. webos_content_json_full contains every json file that I can create via the official Python scripts and ldsWebML from the Gospel Library content project. webos_content_json_partial has all of the same content as the _full zip has except it only has magazines from 2011 where the _full zip has all the magazines back as far as there is available ldsWebML content. Grab both the webos_content_orig.zip and one of the two json zips and extract them to your HP device while it is connected to your computer in USB Drive mode.

Either of the json content zips should include the George Albert Smith manual for Priesthood and Relief Society 2012 lessons along with all the other manuals that will be used in 2012. Let me know if something appears to be missing.

John Hansen
New Member
Posts: 1
Joined: Sat Dec 31, 2011 9:53 pm

Worked perfectly!


Post by fleghorn »

Thanks for the very clear instructions! I have to teach chapter 1 in the morning and I would much rather use my TouchPad. I appreciate the work you put into this to make the updated content available.
New Member
Posts: 1
Joined: Sun Jan 01, 2012 5:36 pm


Post by knowltonjball »

I have tried the above instructions a few times and I keep getting either no content showing or an error message Could not load the topic. What am I missing.

New Member
Posts: 13
Joined: Thu Aug 25, 2011 5:42 am


Post by ljerryd »


I was wondering if any of the zips have the Book of Mormon Institute Manual included? I loaded your original zip and that one is missing, even though some of the others are in there. (Carrying my paper copy for the moment)

New Member
Posts: 22
Joined: Tue Sep 06, 2011 10:08 pm


Post by afanofosc »

The Institute Book of Mormon Teacher Manual is included in either of the JSON content zips but as far as I can tell the student manual is not available in the mobile apps for any platform.

If anyone is having trouble getting this installed just drop me an email (afanofosc at comcast dot net). Following the steps I outlined above should work but if you still have trouble I am pretty sure I can help. It would be easier to handle via email, I think.

John Hansen
New Member
Posts: 22
Joined: Tue Sep 06, 2011 10:08 pm


Post by afanofosc »

afanofosc wrote:I've uploaded zips and my IPK to dropbox at the following URLs:

In my recent post above I had the wrong dropbox link for my IPK file. My apologies. I have corrected the link in the above quote. Perhaps this explains why some people were getting no content at all. If you see that you have both a Gospel Library application and one oddly named Leader Library which, when launched, displays just 2 items that you cannot load then I would ask that you delete that Leader Library application from your device.

John Hansen
Community Moderators
Posts: 8877
Joined: Mon Mar 17, 2008 12:30 am
Location: USA, TX


Post by jdlessley »

Moderator note: The link in the original post has been corrected.
JD Lessley
Have you tried finding your answer on the ChurchofJesusChrist.org Help Center?

Return to “WebOS Gospel Library”