MLS 3.4.1 released - old categories returned, no longer zeroed

Discussions around using and interfacing with the Church MLS program.
crislapi
Senior Member
Posts: 1266
Joined: Mon Jul 07, 2008 4:05 pm
Location: USA

MLS 3.4.1 released - old categories returned, no longer zeroed

#1

Post by crislapi »

MLS 3.4.1 (clarifying - this is 3.4.1b9. 3.4.1 has not been officially released yet) downloaded this week on my computer. I noticed that my categories look like they did back when we transitioned to CUBS. Old deactivated categories have reappeared and, despite having been zeroed, have balances again. This time, though, it seems like they have reposted transfers made in 2010 to 2011. Anyone know why?

For example, a lot of my transfers were made on 23 Oct 2011 to zero out categories. They should be in 2010 but now a detail view of my budget report shows that they posted on 20 Jan 2011. ???

When I look at 2010, the corresponding expense is still there, so why would they have moved the transfer 10 weeks? I was about to start zeroing again but decided to hold off until I can call and talk to someone at LUS about it.

Am I just lucky or are others seeing this as well?
crislapi
Senior Member
Posts: 1266
Joined: Mon Jul 07, 2008 4:05 pm
Location: USA

#2

Post by crislapi »

I take part of this back - it's not just transfers. It seems this has affected checks as well. I see a lot of checks cut in 2010 posting in 2011, too. I wonder if this is part of the new feature associated with 3.4.1, especially since I don't remember these reports having post dates AND (entered) dates before:
Change to the Budget Reports and Income and Expense Reports. This change affects only CUBS units (those on Church Unit Banking Services). Budget Reports and Income and Expense Reports will now take into account the date a financial transaction is posted. The end result is that MLS reports and the Unit Financial Statement will match when run for the same time period. It also means that when these reports are run for prior periods (after adjustments had been made) they will appear the same as when the data was first entered; and adjustments will appear in the month they are made.
User avatar
aebrown
Community Administrator
Posts: 15138
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

#3

Post by aebrown »

crislapi wrote:Am I just lucky or are others seeing this as well?

I'm wondering why you're "lucky" enough to have an official release of 3.4.1. There is no non-beta version of 3.4.1 on mls.lds.org, and I just did three Send/Receives and no new version was sent down. Every indicator I can see shows that 3.4.1 is still in beta and 3.4 is the current release.

Build 20147 was labeled MLS 3.4.1b9. Do you have a newer build than that?

I also saw that you updated the wiki article Timeline of MLS; generally we don't do that until an official release, but I guess that's understandable if you thought it was officially released.
Questions that can benefit the larger community should be asked in a public forum, not a private message.
crislapi
Senior Member
Posts: 1266
Joined: Mon Jul 07, 2008 4:05 pm
Location: USA

#4

Post by crislapi »

aebrown wrote:Build 20147 was labeled MLS 3.4.1b9. Do you have a newer build than that?
Oops. Yes, I have b9. I thought it was 3.4.1 because it downloaded itself. It didn't automatically update from 7 to 8 and I hadn't downloaded it, so I figured it was the automatic update to the current version.

With that cleared up, that still doesn't answer my actual question.
User avatar
aebrown
Community Administrator
Posts: 15138
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

#5

Post by aebrown »

crislapi wrote:Oops. Yes, I have b9. I thought it was 3.4.1 because it downloaded itself. It didn't automatically update from 7 to 8 and I hadn't downloaded it.

With that cleared up, that still doesn't answer my actual question.
That doesn't answer your question, but only someone on the 3.4.1 beta could answer it.

In any case, the behavior you describe is odd enough that I would recommend that you report it as quickly as possible so that hopefully the problem could be found and fixed before 3.4.1 is officially released.
Questions that can benefit the larger community should be asked in a public forum, not a private message.
giffordrb
Member
Posts: 115
Joined: Tue Mar 01, 2011 8:24 am
Location: Eagle Mountain UT

#6

Post by giffordrb »

crislapi wrote:MLS 3.4.1 (clarifying - this is 3.4.1b9. 3.4.1 has not been officially released yet) downloaded this week on my computer. I noticed that my categories look like they did back when we transitioned to CUBS. Old deactivated categories have reappeared and, despite having been zeroed, have balances again. This time, though, it seems like they have reposted transfers made in 2010 to 2011. Anyone know why?

For example, a lot of my transfers were made on 23 Oct 2011 to zero out categories. They should be in 2010 but now a detail view of my budget report shows that they posted on 20 Jan 2011. ???

When I look at 2010, the corresponding expense is still there, so why would they have moved the transfer 10 weeks? I was about to start zeroing again but decided to hold off until I can call and talk to someone at LUS about it.

Am I just lucky or are others seeing this as well?
Have you contacted LUS on this yet (I know it is still early Monday)? This in an interesting behavior and should be looked at asap as the beta cycle for 3.4.1 is coming to an end very soon. We haven't seen this issue during testing but this is why we do beta releases.
Ryan Gifford
MLS
crislapi
Senior Member
Posts: 1266
Joined: Mon Jul 07, 2008 4:05 pm
Location: USA

#7

Post by crislapi »

giffordrb wrote:Have you contacted LUS on this yet (I know it is still early Monday)? This in an interesting behavior and should be looked at asap as the beta cycle for 3.4.1 is coming to an end very soon. We haven't seen this issue during testing but this is why we do beta releases.
Yes. Sent an email with screen shots and a budget report in this morning. Another issue - I can no longer void expenses, even if I just cut the check. From the changes to the escheatment process, I expected it to be grayed out on expenses that are 180 days old or older , but it is grayed out even on expenses I cut yesterday. Sent that one in as well.
crislapi
Senior Member
Posts: 1266
Joined: Mon Jul 07, 2008 4:05 pm
Location: USA

#8

Post by crislapi »

giffordrb wrote:We haven't seen this issue during testing but this is why we do beta releases.
I should mention this is behavior that appeared with b9 release (Sep 23, 2011). That is the release where they tried to modify the dates of financial transactions to match the UFS information. The void issue was there at least during b8.
giffordrb
Member
Posts: 115
Joined: Tue Mar 01, 2011 8:24 am
Location: Eagle Mountain UT

#9

Post by giffordrb »

One known issue that is related to this - currently CUBS isn't aware of a category's status (active vs inactive). It sounds like a setup file was received from CUBS by your unit, setting those categories to the state that CUBS has (which is active in MLS). Can you PM me your unit number (not official support on this issue ;) )?
Ryan Gifford
MLS
freedom55
Member
Posts: 83
Joined: Sun Nov 01, 2009 9:15 pm
Location: BC, Canada

#10

Post by freedom55 »

I noticed some of my old Budget:Budget Allocations subcategories reactivated after the last patch downloded. They didn't have any amounts associated with them so I was able to deactivate them easily.

I am also running 3.4.1 beta.
Post Reply

Return to “MLS Support, Help, and Feedback”