Protection Training login issues

Church Account is the primary user account (user name and password) for accessing online Church resources. Church Account was formerly known as LDS Account. This forum is a space to discuss all things related to Church Accounts (registration, account recovery, user experience, vulnerabilities, etc.).
gardineiro
New Member
Posts: 1
Joined: Thu Sep 05, 2019 9:55 pm

Re: Protection Training login issues

Postby gardineiro » Thu Sep 05, 2019 9:56 pm

same here

jgoggan
New Member
Posts: 32
Joined: Wed May 08, 2013 5:51 am

Re: Protection Training login issues

Postby jgoggan » Thu Sep 05, 2019 11:18 pm

bballrob wrote:I completed the training the first day that it was available(August 15). I know of one other person who did the same thing. THe report to see who has done it isn't reflecting that I've completed. Same with the other person. In looking at the report, it appears that the first date anyone got credit for doing it was August 25. Anyone else seen this issue?


Yes -- I'm seeing EXACTLY this. It looks like those of us who did it right away (like they ASKED us to do), did not get "credit" for completing the training now that the report is available to check. The earliest that we have actually recorded in our Ward is August 26th. Anyone that took it before then seems to be missing that they completed.

That's really frustrating since a lot of our Boy Scout people went right out and did it immediately -- because they are used to having to do Youth Protection Training and such and were curious about the new training from the Church side of things. Now it looks like they'll all have to do it over since it didn't record them as completed. :x

EDIT: So, now I see that this seems directly related to the bug going on now. If I try to go do the training again, it gives the (incorrect) "In order to have this training recorded, you need to have your Church Account linked with your membership record number (MRN)." error that others are getting. It did NOT do that back when I took it around the 16th of August. So, my guess is that it had the same bug then, but didn't REPORT it to us -- so it simply didn't record the training. And now I can't do it over until it is fixed. So, I think those having this issue of having done the training, but not having it show as completed were bitten by this bug long before everyone else -- and therefore it didn't SAY anything, but still just did the training as if you did the "take the training, but don't record it" option that it now shows for those experiencing this bug. :(

Jonnamo
New Member
Posts: 1
Joined: Fri Sep 06, 2019 7:08 am

Re: Protection Training login issues

Postby Jonnamo » Fri Sep 06, 2019 7:14 am

The same thing is happening to my husband and me, Our record numbers are linked but the training keeps asking us to update it and it won't let us proceed unless we access the training without it being recorded. We have tried from multiple computers.

blackt
New Member
Posts: 1
Joined: Fri Sep 06, 2019 7:29 am

Re: Protection Training login issues

Postby blackt » Fri Sep 06, 2019 7:33 am

Schmaff wrote:
segkdowning wrote:My Church Account shows that it is linked with my MRN, but the training just keeps asking me to update it and won’t let me proceed unless I access the training without it being recorded. I did the training without it being recorded, hoping that there was a glitch, but it looks like it was not actually recorded. I tried doing it on my phone and then switched to a laptop. Neither my husband nor I can get it to recognize that our MRN is linked to our Church Account, so it won’t let us proceed past this screen. Our ward clerk doesn't know why.

Any ideas?



This same thing is happening to me. Have you figured out what to do?


I am also having this issue where it says my MRN needs updated, but when I go to the Church Account page, it is all there.

davesudweeks
Senior Member
Posts: 1828
Joined: Sun May 09, 2010 8:16 pm
Location: Oklahoma, USA

Re: Protection Training login issues

Postby davesudweeks » Fri Sep 06, 2019 10:31 am

jgoggan wrote:Yes -- I'm seeing EXACTLY this. It looks like those of us who did it right away (like they ASKED us to do), did not get "credit" for completing the training now that the report is available to check. The earliest that we have actually recorded in our Ward is August 26th. Anyone that took it before then seems to be missing that they completed.

That's really frustrating since a lot of our Boy Scout people went right out and did it immediately -- because they are used to having to do Youth Protection Training and such and were curious about the new training from the Church side of things. Now it looks like they'll all have to do it over since it didn't record them as completed.


We have this in our ward as well, I will be recommending to the members who took it right away (and received the page that said it was completed and recorded) that they post feedback that it appears their training was not properly linked to their membership record. It is possible it can be corrected without them retaking the training, but I took it myself and taking it again is not an onerous task in my opinion. It's much easier and less time consuming than the BSA training.

I took it fairly soon but have no way to know if I'm in this group because I'm not in a calling that requires it so won't show up on the report. I took it to be able to assist others in my ward (I am ward clerk).

russellhltn
Community Administrator
Posts: 28815
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Protection Training login issues

Postby russellhltn » Mon Sep 09, 2019 12:10 pm

For those chomping at the bit to "do something", try clearing the cache and cookies of your browser. It sounds like the system may be retrieving the wrong cookie from your system and confusing you with a different login.

If you can still find a part of lds.org domain that's not redirecting, you could also try logging in there.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

kenziejohns
New Member
Posts: 1
Joined: Mon Sep 09, 2019 12:10 pm

Re: Protection Training login issues

Postby kenziejohns » Mon Sep 09, 2019 12:16 pm

I am having the exact same issue! For some reason I have 2 LDS accounts?? Not sure how/why but when I log in to my valid one with my membership record number it still says I need to enter my MRN? I am so confused and need to do this training because I serve in Primary! Help!! Haha

jgreen13
New Member
Posts: 1
Joined: Tue Sep 17, 2019 8:00 am

Re: Protection Training login issues

Postby jgreen13 » Tue Sep 17, 2019 8:08 am

:D :D :D Thank You!!! I did exactly what you suggested; clearing cache and cookies and it logged me right in!!


russellhltn wrote:For those chomping at the bit to "do something", try clearing the cache and cookies of your browser. It sounds like the system may be retrieving the wrong cookie from your system and confusing you with a different login.

If you can still find a part of lds.org domain that's not redirecting, you could also try logging in there.

russellhltn
Community Administrator
Posts: 28815
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Protection Training login issues

Postby russellhltn » Tue Sep 17, 2019 10:12 am

Glad to hear that works!
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

davesudweeks
Senior Member
Posts: 1828
Joined: Sun May 09, 2010 8:16 pm
Location: Oklahoma, USA

Re: Protection Training login issues

Postby davesudweeks » Tue Sep 17, 2019 10:16 am

kenziejohns wrote:I am having the exact same issue! For some reason I have 2 LDS accounts?? Not sure how/why but when I log in to my valid one with my membership record number it still says I need to enter my MRN? I am so confused and need to do this training because I serve in Primary! Help!! Haha

If you have 2 accounts, no one on this user-to-user help forum will be able to fix it. You need to speak with your ward/branch clerk who can provide the contact info to the Service Center. Only the Service Center can merge or delete accounts.


Return to “Church Account”

Who is online

Users browsing this forum: No registered users and 5 guests