Cannot access main Church website...?

Discuss ideas and suggestions around the Church website.
russellhltn
Community Administrator
Posts: 30412
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Cannot access main Church website...?

Postby russellhltn » Mon Sep 07, 2020 1:26 am

I've had problems with the pages in the past few days. Clearing all data related to the church websites fixed that.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

michael.clark
New Member
Posts: 1
Joined: Tue Apr 14, 2020 10:14 am

Re: Cannot access main Church website...?

Postby michael.clark » Mon Sep 21, 2020 9:01 pm

Similar issues, Chromium on Arch Linux, started more than a month ago. Incognito/deleting all cookies worked, whereas before I was getting slow/no loads for a while. Also have been having trouble with Gospel Library download/display on my tablet, which I suspect is related.

In response to "I'd think we'd see far more complaints if it was wide spread." - here's yet another report. I don't even know where to go to find help, and I've been trying to figure out what was wrong for well over a month! I've suspected the church was under a DOS attack and just not posting about it, and my searches were tuned to that - perhaps it was a self-DOS by an update of some sort? Regardless, a rule of thumb is that every complaint represents a thousand people who've not complained. Given the difficulty of finding a place to even report this (I could search the site for... oh, no I can't, I can't access it!), that ratio could be much higher.

rmrichesjr
Community Moderators
Posts: 2723
Joined: Thu Jan 25, 2007 11:32 am
Location: Dundee, Oregon, USA

Re: Cannot access main Church website...?

Postby rmrichesjr » Mon Sep 21, 2020 9:14 pm

michael.clark wrote:Similar issues, Chromium on Arch Linux, started more than a month ago. Incognito/deleting all cookies worked, whereas before I was getting slow/no loads for a while. ...


Please clarify for me: I'm confused as to whether deleting cookies worked and all problems are gone vs. deleting cookies helped temporarily but the problems are back.

Fwiw: I'm using Firefox ESR on Devuan Linux Ascii and do not recall any serious problems (except for changes to the authentication page) the past month or two. One suggestion would be to make a second Linux user account and try browsing with that account to isolate whether cookies are likely involved. Another would be to install an additional browser or two for experimentation/troubleshooting. I tried Palemoon and was ready to switch from Firefox to Palemoon, but then I found some of the Church's video pages don't work--presumably due to Palemoon's stricter JavaScript interpreter.

mevans
Senior Member
Posts: 1891
Joined: Tue May 22, 2012 12:52 pm
Location: California, USA

Re: Cannot access main Church website...?

Postby mevans » Wed Sep 23, 2020 7:49 am

rmrichesjr wrote:Please clarify for me: I'm confused as to whether deleting cookies worked and all problems are gone vs. deleting cookies helped temporarily but the problems are back.


Clearing cookies often times helps; however we don't know how often the church updates pages. Maybe you clear your cache one day, then they update the site and you go back the next day and it's broken again.

zToddW
New Member
Posts: 10
Joined: Tue Jul 29, 2014 6:48 pm

Re: Cannot access main Church website...?

Postby zToddW » Sat Oct 24, 2020 8:56 pm

I know this is almost a couple months old, but we've had related issues like this, off and on again, for a few months now. What happens most often for me is that there are certain elements missing from the webpage.

I'm just wondering if anyone might know if the website programmers or the other IT people understand these issues are happening, I guess because of website updates, and if they are trying to do things to account for leftover cookies from past versions of website pages. When there's an update, it should be possible for the website / webpage to delete the old cookies, if it is programmed correctly.

barefut
New Member
Posts: 1
Joined: Sun Apr 26, 2020 1:49 pm

Re: Cannot access main Church website...?

Postby barefut » Sun Oct 25, 2020 2:06 pm

Have the same problem.
I am using Linux Mint. It takes about 2 minutes to load a page.

Here is my traceroute:

traceroute to churchofjesuschrist.org (216.49.176.43), 30 hops max, 60 byte packets
----
3 agg63.macdny0902h.northeast.rr.com (24.58.232.253) 22.408 ms 22.433 ms 22.420 ms
4 agg54.rochnyei02r.northeast.rr.com (24.58.52.6) 12.125 ms 19.823 ms 19.750 ms
5 be28.rochnyei01r.northeast.rr.com (24.58.32.74) 20.641 ms 20.636 ms 20.623 ms
6 bu-ether15.chcgildt87w-bcr00.tbone.rr.com (66.109.6.72) 33.176 ms bu-ether13.tustca4200w-bcr00.tbone.rr.com (66.109.6.2) 29.216 ms bu-ether15.chcgildt87w-bcr00.tbone.rr.com (66.109.6.72) 29.123 ms
7 bu-ether11.chctilwc00w-bcr00.tbone.rr.com (66.109.6.21) 29.548 ms 27.365 ms 31.920 ms
8 ae-13.edge2.Chicago10.Level3.net (4.68.37.137) 39.094 ms 39.066 ms 39.156 ms
9 ae-6-3.bar1.SaltLakeCity1.Level3.net (4.69.220.109) 78.579 ms 77.201 ms 77.231 ms
10 CORPORATION.bar1.SaltLakeCity1.Level3.net (4.35.168.14) 110.796 ms 106.129 ms 111.318 ms
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 churchofjesuschrist.org (216.49.176.43) 79.828 ms 79.209 ms 78.335 ms

Looks like it's getting stuck in SLC somewhere.
Did this traceroute for the past couple weeks, with the same problem at the same place

If you would like to do the same, in Windows, pull up 'cmd' prompt (program) and type 'tracert churchofjesuschrist.org' then enter

rmrichesjr
Community Moderators
Posts: 2723
Joined: Thu Jan 25, 2007 11:32 am
Location: Dundee, Oregon, USA

Re: Cannot access main Church website...?

Postby rmrichesjr » Sun Oct 25, 2020 3:14 pm

barefut wrote:Have the same problem.
I am using Linux Mint. It takes about 2 minutes to load a page.

Here is my traceroute:

traceroute to churchofjesuschrist.org (216.49.176.43), 30 hops max, 60 byte packets
...
16 churchofjesuschrist.org (216.49.176.43) 79.828 ms 79.209 ms 78.335 ms

Looks like it's getting stuck in SLC somewhere.
Did this traceroute for the past couple weeks, with the same problem at the same place

If you would like to do the same, in Windows, pull up 'cmd' prompt (program) and type 'tracert churchofjesuschrist.org' then enter


Another Linux user? Cool! What browser are you using? Did you already try clearing the browser cache and deleting cookies? Perchance have you tried setting the user agent string to impersonate a more popular commercial OS?

For comparison, Church website pages load fairly well for me with Firefox 78.4.0esr. My ISP is Ziply Fiber, formerly known as Frontier, formerly served by Verizon. I had to add '-T' to the traceroute command from my Devuan Ascii machine, and that gets me this:

traceroute to churchofjesuschrist.org (216.49.176.43), 30 hops max, 44 byte packets
[hops 1 and 2 are my two NAT routers (so I can have an untrusted LAN for my work Windows laptop)]
3 * * *
... [hops 3-21 are all '* * *']
21 * * *
22 directory-api.churchofjesuschrist.org (216.49.176.43) 55.054 ms 57.446 ms 57.786 ms


IIUC, IP address 216.49.176.43 is the gateway from the outside world into the Church's network, which would seem to mean that if you get there your packets are getting through.

rmrichesjr
Community Moderators
Posts: 2723
Joined: Thu Jan 25, 2007 11:32 am
Location: Dundee, Oregon, USA

Re: Cannot access main Church website...?

Postby rmrichesjr » Sun Oct 25, 2020 3:31 pm

barefut wrote:Have the same problem.
I am using Linux Mint. It takes about 2 minutes to load a page.

...


Two more long-shot ideas:

1) Do you have any delays doing DNS lookups? With the enormous number of side URLs some sites load, even a minor DNS delay could cause a full page load to take a huge amount of time.

2) If you were to create a new user account and make a fresh browser profile for that user, that could rule out browser, cache, and cookie issues.

3) If you're using a proxy (squid3 or similar), could that be part of the problem? If your test user were to configure the browser to by pass the proxy, that could help rule out the proxy.

(Okay, I can't count very well. :-)

russellhltn
Community Administrator
Posts: 30412
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: Cannot access main Church website...?

Postby russellhltn » Sun Oct 25, 2020 8:38 pm

rmrichesjr wrote:If you were to create a new user account and make a fresh browser profile for that user, that could rule out browser, cache, and cookie issues.

If your browser has something like incognito mode, I'd give that a try.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.

rmrichesjr
Community Moderators
Posts: 2723
Joined: Thu Jan 25, 2007 11:32 am
Location: Dundee, Oregon, USA

Re: Cannot access main Church website...?

Postby rmrichesjr » Sun Oct 25, 2020 8:55 pm

russellhltn wrote:If your browser has something like incognito mode, I'd give that a try.


The advantage of a new (test) user account is it also eliminates anything else (like userChrome.js and about:config settings, for example) which incognito mode might not side-step. With the OS in question being Linux, the overhead/effort to create a new user account is less than a minute, and only a few seconds to delete all traces of the account.


Return to “Main Church Website”

Who is online

Users browsing this forum: No registered users and 2 guests