I can not reinstall

Discussions around the Android version of the Gospel Library application.
Post Reply
New Member
Posts: 1
Joined: Mon Dec 23, 2019 5:13 pm

I can not reinstall


Post by sidecar »

I uninstalled because it wouldn't download some things, Now I can't install it. It just gets hung up on the updating library part and says it can't download the library updates. I have lots of room on my sd card and have even tried a different sd card. I have also shut down the phone and restarted a few times. I it a samsung S7. It has been weeks that I have been trying and I really need this app. Any ideas I can try?
Posts: 90
Joined: Sun Feb 27, 2011 11:57 am

Re: I can not reinstall


Post by carsonm »

Without knowing the version of Andriod you are running on your S7, If it a bit older version of Andriod you might reference this post.

. viewtopic.php?f=102&t=34113
User avatar
Community Moderators
Posts: 5700
Joined: Mon Sep 26, 2011 9:42 pm
Location: Utah

Re: I can not reinstall


Post by sbradshaw »

Are you still seeing this problem today? (There was a recent content update that might have fixed the issue.)
If not, do you have any VPNs, content blockers, or web filtering services installed that might be blocking the app's access to the content servers?
Samuel Bradshaw • If you desire to serve God, you are called to the work.
New Member
Posts: 1
Joined: Wed Jan 22, 2020 4:14 pm

Re: I can not reinstall


Post by Tacoma3218 »

I run a Samsung Note 10+ and recently had the same problem. I'm running the most current Android version (as far as I'm aware) and yet after multiple attempts to redownload it simply won't work... much like above, it gets stuck on the 'Updating Library' screen after getting half way. It's also worth mentioning I am not using an SD card, all data is supposedly in the internal storage of the device.
New Member
Posts: 2
Joined: Sun Oct 06, 2019 12:34 am

Re: I can not reinstall


Post by dara1hunter »

I'm having the same problem. I have 1.2G left on my phone, a Galaxy J7 Prine and have installed the layest app. I uninstalled just a week ago because it wouldn't download a magazine. Now it's continually stuck on the initial loading "Updating" splash screen. No web blockers, no vpn. Cleared cache and data, restarted phone, etc. Previously, I would get the option on lds.org to open in the GL app, but I don't have that option anymore.

Is there anymore info on this issue? It seems to be reoccurring quite often.
Community Administrator
Posts: 32102
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: I can not reinstall


Post by russellhltn »

Some have found that disabling all internet access will get it to open. Once initialized, it works ok with access.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
Post Reply

Return to “Android Gospel Library”