FHC ERR_TUNNEL_CONNECTION_FAILED

Issues related to the use and operation of Family History Centers
superdave98
New Member
Posts: 48
Joined: Tue Feb 06, 2007 8:21 am
Location: Ukiah, California
Contact:

FHC ERR_TUNNEL_CONNECTION_FAILED

#1

Post by superdave98 »

Greetings,

One of our Family History Centers is unable to access any of the premium websites. When we try, we get the "ERR_TUNNEL_CONNECTION_FAILED" error.

I've reinstalled the FHC Services Portal and the Portal Check says it's good to go. I've verified the machines are on the "Special Purpose" port on the firewall, showing the expected IP address range. I looked at the proxy settings and it grabs the proxy information from a machine in the familysearch.org domain. One of the more technical members in the ward has been on the phone with Family Search support and they're telling him that its the Internet connection. The Internet connection is a Cradlepoint LTE router like we use in other buildings in the stake and it's 15M down and 10M up, so it has plenty of bandwidth for these two computers. It will go any other site including FamilySearch.org and anything on the commodity Internet without any issues.

Anyone have any ideas what I'm missing? I'm having a super hard time thinking that it's the Internet connection.

Dave
superdave98
New Member
Posts: 48
Joined: Tue Feb 06, 2007 8:21 am
Location: Ukiah, California
Contact:

Re: FHC ERR_TUNNEL_CONNECTION_FAILED

#2

Post by superdave98 »

Oh, and if I turn off the proxy, it does go to the premium websites, but of course without the proxy, you don't get in. I've checked the date/time and that the browser versions are the latest. It does it in every browser. I rebooted the firewall. It seems to me like it's most likely a firewall issue, but I'm stumped. I'm hoping for a nugget of brilliance from someone. ;-)

Dave
russellhltn
Community Administrator
Posts: 31287
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: FHC ERR_TUNNEL_CONNECTION_FAILED

#3

Post by russellhltn »

superdave98 wrote:It seems to me like it's most likely a firewall issue, but I'm stumped.
Have the STS check the filtering level on the firewall for that site. It's possible that is having an effect.
superdave98 wrote:I've verified the machines are on the "Special Purpose" port on the firewall, showing the expected IP address range.
Just to double-check - that range should be a 10.x.x.x address. Also, at some point the firewall/switch setup probably has been changed out. It's no longer a set port on the firewall itself, but an assigned port on a cisco managed switch set in Technology Manager.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
superdave98
New Member
Posts: 48
Joined: Tue Feb 06, 2007 8:21 am
Location: Ukiah, California
Contact:

Re: FHC ERR_TUNNEL_CONNECTION_FAILED

#4

Post by superdave98 »

Thanks for the response. I'm the STS. ;-)

The filtering level is Managed, which as I understand is the most lenient. Yes, they're in the right 10.x.x.x IP address range.

I haven't yet installed the Meraki switch at this location, so it's still on a non-managed switch plugged into the firewall.

Dave
russellhltn
Community Administrator
Posts: 31287
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: FHC ERR_TUNNEL_CONNECTION_FAILED

#5

Post by russellhltn »

superdave98 wrote:I haven't yet installed the Meraki switch at this location, so it's still on a non-managed switch plugged into the firewall.
I'd look into doing the upgrade. It's possible there's done kind of change that's affecting the proxy.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
superdave98
New Member
Posts: 48
Joined: Tue Feb 06, 2007 8:21 am
Location: Ukiah, California
Contact:

Re: FHC ERR_TUNNEL_CONNECTION_FAILED

#6

Post by superdave98 »

I have other buildings where I haven't upgraded the switches yet and their FHCs can still access the premium sites. I'll give that a try though. Thanks.
superdave98
New Member
Posts: 48
Joined: Tue Feb 06, 2007 8:21 am
Location: Ukiah, California
Contact:

Re: FHC ERR_TUNNEL_CONNECTION_FAILED

#7

Post by superdave98 »

Someone else mentioned that they had machines with similar issues and it was that the proxy server the church was using had changed and re-imaging the machines solved the issue. They were just reimaged last year, so I don't know if that's the solution, but a proxy server change would definitely explain what I'm seeing. I'll go see what the proxy settings are in a working building and compare.
superdave98
New Member
Posts: 48
Joined: Tue Feb 06, 2007 8:21 am
Location: Ukiah, California
Contact:

Re: FHC ERR_TUNNEL_CONNECTION_FAILED

#8

Post by superdave98 »

So, the saga continues. When we last left our hero, he had received suggestions to replace the switch with the new Meraki switches and to re-image the computer. In further investigation, he found that the local FHC near his home also had the same issue. Since that building is 5 minutes away from his home instead of the 1.5 hours away that the original building was, he decided to focus on the nearby building first.

OK, enough third-person hero stuff.

I've replaced the switches in this building. No improvement. I just spent about 4 hours of my life downloading the Windows 10 FHC image from the FHC Application Finder and re-imaging one of the machines. The machine came up great. I ran the Portal Status program and it said the portal was working. Unfortunately, all three of the installed browsers give me the same error that I saw before. I'm at a loss at this point. Unfortunately, I work during the day, so it's tough to call FHC support. I guess I'll have to take some time off and do just that.

I'm having a hard time believing that I'm the only person with this issue. I must be missing something really obvious since I have at least two FHCs with this issue.
superdave98
New Member
Posts: 48
Joined: Tue Feb 06, 2007 8:21 am
Location: Ukiah, California
Contact:

Re: FHC ERR_TUNNEL_CONNECTION_FAILED

#9

Post by superdave98 »

Another quick update. I did actually just find a help item for this issue in the Family Search support website with the title 'Family history center getting the error: "The proxy server is refusing connections..."' So, I guess I'm not the only one. Unfortunately, their solution was to just run"FHC Services Portal Installer" which did not resolve my issue.
russellhltn
Community Administrator
Posts: 31287
Joined: Sat Jan 20, 2007 2:53 pm
Location: U.S.

Re: FHC ERR_TUNNEL_CONNECTION_FAILED

#10

Post by russellhltn »

superdave98 wrote:I have other buildings where I haven't upgraded the switches yet and their FHCs can still access the premium sites.
How many FHCs does your stake have? Looking in CDOL, I only see two. If some of your locations are not recognized by church headquarters as having a FHC, that would be a problem.
Have you searched the Help Center? Try doing a Google search and adding "site:churchofjesuschrist.org/help" to the search criteria.

So we can better help you, please edit your Profile to include your general location.
Post Reply

Return to “Family History Centers”