Turn off autoplay in an embed video from LDS media library?

Some discussions just don't fit into a well defined box. Use this forum to discuss general topics and issues revolving around the Church and the technology offerings we use and share.
Post Reply
jackandrews
New Member
Posts: 3
Joined: Mon May 30, 2011 11:40 am

Turn off autoplay in an embed video from LDS media library?

#1

Post by jackandrews »

Hi, I have a blog that I post a new "CTR" to every week. I've embedded a video of President Uchtdorf that autoplays, and I don't want it to. I can't figure out what to take out of the HTML--or add to it--that will stop autoplay. Ideas?
User avatar
aebrown
Community Administrator
Posts: 15138
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

#2

Post by aebrown »

jackandrews wrote:Hi, I have a blog that I post a new "CTR" to every week. I've embedded a video of President Uchtdorf that autoplays, and I don't want it to. I can't figure out what to take out of the HTML--or add to it--that will stop autoplay. Ideas?
That's tough to answer without knowing how you embedded it. Is it the standard YouTube embed? HTML5? Flash? If you include a link to your blog, someone could easily take a look and tell you how to fix it.
Questions that can benefit the larger community should be asked in a public forum, not a private message.
russelljd
Member
Posts: 66
Joined: Sat Feb 13, 2010 7:53 am
Location: Salt Lake City, Utah, USA

#3

Post by russelljd »

If you are using videos from the media library section you just need to add a parameter to the embed. It is:

<param name="autoStart" value="false" />

The videos from the media library are served up using the Brightcove platform. You can read about setting player parameters at: http://support.brightcove.com/en/docs/p ... parameters
jackandrews
New Member
Posts: 3
Joined: Mon May 30, 2011 11:40 am

Didn't work...

#4

Post by jackandrews »

The video is from the LDS Media library. It's "Reflection in the Water" by President Uchtdorf. I embedded it in my blog..."asmallandsimplething.blogspot.com".

I added the parameter to a number of different places in the HTML code, to no avail. It still starts automatically. Here's the link:

http://asmallandsimplething.blogspot.co ... bbish.html

Thanks so much!
User avatar
aebrown
Community Administrator
Posts: 15138
Joined: Tue Nov 27, 2007 8:48 pm
Location: Sandy, Utah

#5

Post by aebrown »

jackandrews wrote:I added the parameter to a number of different places in the HTML code, to no avail. It still starts automatically. Here's the link:

Thanks for supplying the link. I was able to play with it and find the correct place to add the parameter.

Inside the <object> tag is an <embed> tag. The embed tag has several attributes; one of them is "flashVars". The value of flashVars is a rather long string enclosed in double quotes. Right before the ending double quote you will see dynamicStreaming=true ; you need to add &autoStart=false right after that and before the ending double quote. So the flashvars attribute will then look like:

flashVars="...dynamicStreaming=true&autoStart=false"

where the ... represents the existing value before the dynamicStreaming parameter (when I look at this post, there is a space between the s and the e of "false" but there should be no space there).

In my test this worked fine. Give it a try and see how it works for you.
Questions that can benefit the larger community should be asked in a public forum, not a private message.
jackandrews
New Member
Posts: 3
Joined: Mon May 30, 2011 11:40 am

Thank you!

#6

Post by jackandrews »

aebrown...Thank You! That worked great!
Post Reply

Return to “General Discussions”